summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-02-18 20:11:28 +0100
committerDavid Seifert <soap@gentoo.org>2020-02-18 20:11:28 +0100
commit6339b345f14e80c00a868e83bc4d145b27cf6902 (patch)
tree3e33e02e09bda240c26163d32ef9d0ac74f9f9e1 /dev-util/dmake
parentdev-util/cutils: Port to EAPI 7 (diff)
downloadgentoo-6339b345f14e80c00a868e83bc4d145b27cf6902.tar.gz
gentoo-6339b345f14e80c00a868e83bc4d145b27cf6902.tar.bz2
gentoo-6339b345f14e80c00a868e83bc4d145b27cf6902.zip
dev-util/dmake: Port to EAPI 7
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-util/dmake')
-rw-r--r--dev-util/dmake/dmake-4.12.2.ebuild17
1 files changed, 7 insertions, 10 deletions
diff --git a/dev-util/dmake/dmake-4.12.2.ebuild b/dev-util/dmake/dmake-4.12.2.ebuild
index 9029df2aefed..0f81ca5ffa72 100644
--- a/dev-util/dmake/dmake-4.12.2.ebuild
+++ b/dev-util/dmake/dmake-4.12.2.ebuild
@@ -1,9 +1,7 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
-
-inherit eutils
+EAPI=7
DESCRIPTION="Improved make"
HOMEPAGE="https://github.com/mohawk2/dmake"
@@ -12,24 +10,23 @@ SRC_URI="http://${PN}.apache-extras.org.codespot.com/files/${P}.tar.bz2"
LICENSE="GPL-1"
SLOT="0"
KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE=""
# test failure, reported upstream at
# https://code.google.com/a/apache-extras.org/p/dmake/issues/detail?id=1
RESTRICT="test"
-DEPEND="
+BDEPEND="
app-arch/unzip
- sys-apps/groff
-"
-RDEPEND=""
+ sys-apps/groff"
src_prepare() {
+ default
+
# make tests executable, bug #404989
chmod +x tests/targets-{1..12} || die
}
-src_install () {
+src_install() {
default
newman man/dmake.tf dmake.1
}