summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-12 18:32:53 +0000
committerSam James <sam@gentoo.org>2022-05-12 18:33:23 +0000
commit8dae3b20d22eef50d708b547a11000962b2c0106 (patch)
tree841f50c47980fae41e1d3f8f8153458937e5471e /dev-util/cvise
parentdev-java/ant-core: MAVEN_ID (diff)
downloadgentoo-8dae3b20d22eef50d708b547a11000962b2c0106.tar.gz
gentoo-8dae3b20d22eef50d708b547a11000962b2c0106.tar.bz2
gentoo-8dae3b20d22eef50d708b547a11000962b2c0106.zip
dev-util/cvise: fix Python shebang on cvise
Also, drop obsolete LLVM impls. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/cvise')
-rw-r--r--dev-util/cvise/cvise-2.4.0-r1.ebuild (renamed from dev-util/cvise/cvise-2.4.0.ebuild)11
1 files changed, 8 insertions, 3 deletions
diff --git a/dev-util/cvise/cvise-2.4.0.ebuild b/dev-util/cvise/cvise-2.4.0-r1.ebuild
index f1901e09417d..0da34e94e399 100644
--- a/dev-util/cvise/cvise-2.4.0.ebuild
+++ b/dev-util/cvise/cvise-2.4.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -24,8 +24,6 @@ DEPEND="
|| (
sys-devel/clang:13
sys-devel/clang:12
- sys-devel/clang:11
- sys-devel/clang:10
)
<sys-devel/clang-$(( LLVM_MAX_SLOT + 1 )):="
RDEPEND="${DEPEND}
@@ -65,3 +63,10 @@ src_test() {
cd "${BUILD_DIR}" || die
epytest
}
+
+src_install() {
+ cmake_src_install
+
+
+ python_fix_shebang "${ED}"/usr/bin/cvise
+}