summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-18 08:02:12 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-18 09:54:38 +0200
commit90e5a73283e89352e724bf622b48828ce7ecf965 (patch)
treee2b90fd2335c94dc787d630ae7c43ea3dfa6e24d /dev-util/catfish
parentsys-libs/libomp: Backport -lm linking fix (diff)
downloadgentoo-90e5a73283e89352e724bf622b48828ce7ecf965.tar.gz
gentoo-90e5a73283e89352e724bf622b48828ce7ecf965.tar.bz2
gentoo-90e5a73283e89352e724bf622b48828ce7ecf965.zip
dev-util/catfish: Bump to 4.16.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-util/catfish')
-rw-r--r--dev-util/catfish/Manifest1
-rw-r--r--dev-util/catfish/catfish-4.16.4.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-util/catfish/Manifest b/dev-util/catfish/Manifest
index b62173cb447d..774af025cb9d 100644
--- a/dev-util/catfish/Manifest
+++ b/dev-util/catfish/Manifest
@@ -1 +1,2 @@
DIST catfish-4.16.3.tar.bz2 271642 BLAKE2B cebadeeb478a041ba6f815aec81b18d317ebf468bfe0699e33c4550a2f4b1b3377cbabd08d7d6504c3d94169b2be68d35ade9bd77e018ea7c099370ccf4ac124 SHA512 23ffa160b0593033a9696644fd00c48e4a6f54dc25448f975f0949aece50d8e4fbb45b9ad086a8e14072ac1dab27e0b4ecd19af0f31a5b4a775b17e18b00c7bb
+DIST catfish-4.16.4.tar.bz2 284259 BLAKE2B 97b0cc1f082dc20865a465c282581a23b85df89cc0745d6b69617eee94ff88d04f1e63c1acf64b524345fcbdb1817feda289dc49a57e08b747b2d57388180e40 SHA512 729359e737d5faf8a97caf82d1bc709be46baf76d93f0a7007e27fa96d3f2dfe9e2c316cdba991a38c5333db26c37f18cc4ca7f8468087cad754d44bd1e2677c
diff --git a/dev-util/catfish/catfish-4.16.4.ebuild b/dev-util/catfish/catfish-4.16.4.ebuild
new file mode 100644
index 000000000000..a726c1515f18
--- /dev/null
+++ b/dev-util/catfish/catfish-4.16.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="A frontend for find, (s)locate, doodle, tracker, beagle, strigi and pinot"
+HOMEPAGE="https://docs.xfce.org/apps/catfish/start"
+SRC_URI="https://archive.xfce.org/src/apps/catfish/${PV%.*}/${P}.tar.bz2"
+
+# yep, GPL-2 only
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.42
+ dev-libs/gobject-introspection
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ x11-libs/gdk-pixbuf[introspection]
+ >=x11-libs/gtk+-3.22:3[introspection]
+ x11-libs/pango[introspection]
+ >=xfce-base/xfconf-4.14[introspection]
+ virtual/freedesktop-icon-theme
+"
+BDEPEND="
+ dev-python/python-distutils-extra[${PYTHON_USEDEP}]
+ sys-devel/gettext
+"
+
+src_install() {
+ distutils-r1_src_install
+ rm -r "${ED}"/usr/share/doc/catfish || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}