summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/bam
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/bam')
-rw-r--r--dev-util/bam/Manifest1
-rw-r--r--dev-util/bam/bam-0.4.0-r1.ebuild49
-rw-r--r--dev-util/bam/files/0.4.0/Makefile22
-rw-r--r--dev-util/bam/files/0.4.0/bam-0.4.0-test.py.patch11
-rw-r--r--dev-util/bam/metadata.xml10
5 files changed, 93 insertions, 0 deletions
diff --git a/dev-util/bam/Manifest b/dev-util/bam/Manifest
new file mode 100644
index 000000000000..195b940264eb
--- /dev/null
+++ b/dev-util/bam/Manifest
@@ -0,0 +1 @@
+DIST bam-0.4.0.tar.bz2 164033 SHA256 56030670aa21e227ce0a00f1ee0c9b5129469a6e69e7b67c3dd459d2fce6207d SHA512 10ba53b05ac1604a9e9a01f4c008a8cbdc4e4e9df2fc039c8ca59251461e4c5f95770b5b72945d07693db7abe7cd312bc38725686b4d509d5dc21a585fffc810 WHIRLPOOL 01399ae9347b52318b7589b05e156362948773ef7b7060b299b79c3d8519565d38cdc786257b929a5f0c3c96d56eedcdd4adc4702ff9c9773c2037adb52414a8
diff --git a/dev-util/bam/bam-0.4.0-r1.ebuild b/dev-util/bam/bam-0.4.0-r1.ebuild
new file mode 100644
index 000000000000..d3a69b71df2c
--- /dev/null
+++ b/dev-util/bam/bam-0.4.0-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils python-any-r1 toolchain-funcs
+
+DESCRIPTION="Fast and flexible Lua-based build system"
+HOMEPAGE="http://matricks.github.com/bam/"
+SRC_URI="http://github.com/downloads/matricks/${PN}/${P}.tar.bz2"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc test"
+
+RDEPEND="dev-lang/lua:="
+DEPEND="${RDEPEND}
+ doc? ( ${PYTHON_DEPS} )
+ test? ( ${PYTHON_DEPS} )"
+
+pkg_setup() {
+ if use doc || use test; then
+ python-any-r1_pkg_setup
+ fi
+}
+
+src_prepare() {
+ cp "${FILESDIR}"/${PV}/Makefile "${S}"/Makefile || die "cp failed"
+ epatch "${FILESDIR}"/${PV}/${P}-test.py.patch
+ tc-export CC
+}
+
+src_compile() {
+ emake ${PN}
+ if use doc; then
+ "${PYTHON}" scripts/gendocs.py || die "doc generation failed"
+ fi
+}
+
+src_install() {
+ dobin ${PN}
+ if use doc; then
+ dohtml docs/${PN}{.html,_logo.png}
+ fi
+}
diff --git a/dev-util/bam/files/0.4.0/Makefile b/dev-util/bam/files/0.4.0/Makefile
new file mode 100644
index 000000000000..d64f43abcd11
--- /dev/null
+++ b/dev-util/bam/files/0.4.0/Makefile
@@ -0,0 +1,22 @@
+LIBS += -lm -lpthread -llua -ldl
+TARGETS = txt2c internal_base bam
+BAM_OBJ = $(patsubst %.c,%.o,$(wildcard src/*.c))
+TXT2C_LUA = $(wildcard src/*.lua)
+
+all: $(TARGETS)
+
+txt2c: src/tools/txt2c
+
+internal_base: src/internal_base.h
+
+src/internal_base.h:
+ src/tools/txt2c $(TXT2C_LUA) > src/internal_base.h
+
+bam: txt2c internal_base $(BAM_OBJ)
+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(BAM_OBJ) $(LIBS)
+
+test: $(TARGETS)
+ python scripts/test.py
+
+clean:
+ rm -f $(BAM_OBJ) $(TARGETS) src/internal_base.h src/tools/txt2c
diff --git a/dev-util/bam/files/0.4.0/bam-0.4.0-test.py.patch b/dev-util/bam/files/0.4.0/bam-0.4.0-test.py.patch
new file mode 100644
index 000000000000..5ea2acd3e440
--- /dev/null
+++ b/dev-util/bam/files/0.4.0/bam-0.4.0-test.py.patch
@@ -0,0 +1,11 @@
+--- scripts/test.py.old 2010-03-22 19:23:23.000000000 +0100
++++ scripts/test.py 2010-03-22 19:23:43.000000000 +0100
+@@ -178,6 +178,8 @@
+ print "FAILED TESTS:"
+ for t in failed_tests:
+ print "\t"+t
++ sys.exit(1)
+ else:
+ print "ALL TESTS PASSED!"
++ sys.exit(0)
+
diff --git a/dev-util/bam/metadata.xml b/dev-util/bam/metadata.xml
new file mode 100644
index 000000000000..89a3497cd9b1
--- /dev/null
+++ b/dev-util/bam/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">downloads/matricks</remote-id>
+ </upstream>
+</pkgmetadata>