summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-05-10 09:06:51 +0200
committerHans de Graaff <graaff@gentoo.org>2023-05-10 09:06:51 +0200
commit6fbb23e9be4ab5be2366d945995b7be5a1952b58 (patch)
tree9640b69c4bd67e326f19a3993bdacaf7a0ead91a /dev-ruby
parentdev-java/jakartaee-migration: bump to 1.0.7 (diff)
downloadgentoo-6fbb23e9be4ab5be2366d945995b7be5a1952b58.tar.gz
gentoo-6fbb23e9be4ab5be2366d945995b7be5a1952b58.tar.bz2
gentoo-6fbb23e9be4ab5be2366d945995b7be5a1952b58.zip
dev-ruby/oauth2: add 1.4.11
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/oauth2/Manifest1
-rw-r--r--dev-ruby/oauth2/metadata.xml2
-rw-r--r--dev-ruby/oauth2/oauth2-1.4.11.ebuild59
3 files changed, 61 insertions, 1 deletions
diff --git a/dev-ruby/oauth2/Manifest b/dev-ruby/oauth2/Manifest
index 23354914b0ab..eb627df9186a 100644
--- a/dev-ruby/oauth2/Manifest
+++ b/dev-ruby/oauth2/Manifest
@@ -1 +1,2 @@
DIST oauth2-1.4.10.tar.gz 65553 BLAKE2B 4b147a97536ae04b81ca5bc41117bc31c577aae9b7dc1f4f34830d3cd7b7013098e90ae83997c4917ca25e858b8738398eb708bfee954882359ed14b8e810172 SHA512 cee9e1f890f66252451cc22ab7135dda60c73bb200f2f1659a450b09dccc0a219982625ec45866dc9153669a4d35fb543fb6de497bfa83522b99c66e9c8b9d9b
+DIST oauth2-1.4.11.tar.bz2 65622 BLAKE2B 9a09e69eb2389289d5b048388dd52dd6edcf289c4d7262ead05cca7dd27b261b6f432e023ac3c34aa77d6fa33bca5d870726b96cf5bf85eeec3561e9b53f9501 SHA512 12a9133cd5813eed00c2a22995630a7fdb611b0d76b06eeb8c938fd826831ea37556822246f21a739ba427c74135e6c2046edc1fb008725c55f3b1000ab5a945
diff --git a/dev-ruby/oauth2/metadata.xml b/dev-ruby/oauth2/metadata.xml
index 59f7d3b5910c..09a70a6befc5 100644
--- a/dev-ruby/oauth2/metadata.xml
+++ b/dev-ruby/oauth2/metadata.xml
@@ -6,6 +6,6 @@
<name>Gentoo Ruby Project</name>
</maintainer>
<upstream>
- <remote-id type="github">intridea/oauth2</remote-id>
+ <remote-id type="gitlab">oauth-xx/oauth2</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-ruby/oauth2/oauth2-1.4.11.ebuild b/dev-ruby/oauth2/oauth2-1.4.11.ebuild
new file mode 100644
index 000000000000..286c19cd9e96
--- /dev/null
+++ b/dev-ruby/oauth2/oauth2-1.4.11.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_TASK_TEST="none"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="oauth2.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Wrapper for the OAuth 2.0 protocol with a similar style to the OAuth gem"
+HOMEPAGE="https://gitlab.com/oauth-xx/oauth2"
+SRC_URI="https://gitlab.com/oauth-xx/oauth2/-/archive/v${PV}/oauth2-${PV}.tar.bz2"
+RUBY_S="oauth2-v${PV}-d41fb6e8feef3b0b0382dedc0ede82f5ca7854cd"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_rdepend "
+ || ( dev-ruby/faraday:2 dev-ruby/faraday:1 )
+ dev-ruby/jwt:2
+ >=dev-ruby/multi_json-1.3 =dev-ruby/multi_json-1*
+ >=dev-ruby/multi_xml-0.5:0
+ >=dev-ruby/rack-1.2:* <dev-ruby/rack-4:*"
+ruby_add_bdepend "test? (
+ >=dev-ruby/addressable-2.3
+ >=dev-ruby/rexml-3.2:3
+ dev-ruby/rspec:3
+ dev-ruby/rspec-pending_for
+ dev-ruby/rspec-stubbed_env
+)"
+
+all_ruby_prepare() {
+ sed \
+ -e '/silent/I s:^:#:' \
+ -e '/require.*oauth2/arequire "oauth2/version"' \
+ -i spec/helper.rb || die
+
+ sed -i -e '/yardstick/,/^end/ s:^:#:' \
+ -e '/bundler/I s:^:#:' Rakefile || die
+
+ # Avoid spec that is too fragile in relation to ENV
+ sed -i -e '/outputs to $stdout when OAUTH_DEBUG=true/a skip "fragile ENV stubbing"' spec/oauth2/client_spec.rb || die
+
+ sed -i -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+each_ruby_test() {
+ CI=true ${RUBY} -S rspec-3 --format progress spec || die
+}