summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-15 07:24:32 +0000
committerSam James <sam@gentoo.org>2023-03-18 00:01:55 +0000
commit3a078465a8e26099a35dc4374ae8aaf2dbda406c (patch)
treef00d5d495d362fd15cb55e5da32678dac2ee9fe0 /dev-ruby
parentdev-ruby/crack: enable ruby32 (diff)
downloadgentoo-3a078465a8e26099a35dc4374ae8aaf2dbda406c.tar.gz
gentoo-3a078465a8e26099a35dc4374ae8aaf2dbda406c.tar.bz2
gentoo-3a078465a8e26099a35dc4374ae8aaf2dbda406c.zip
dev-ruby/mocha: enable ruby32 for 1.16.0
``` Finished in 0.151366s, 2530.2874 runs/s, 1909.2769 assertions/s. 383 runs, 289 assertions, 0 failures, 0 errors, 0 skips ``` Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/mocha/files/mocha-1.16.0-ruby32.patch (renamed from dev-ruby/mocha/files/mocha-2.0.2-ruby32.patch)0
-rw-r--r--dev-ruby/mocha/mocha-1.16.0.ebuild8
-rw-r--r--dev-ruby/mocha/mocha-2.0.2.ebuild2
3 files changed, 7 insertions, 3 deletions
diff --git a/dev-ruby/mocha/files/mocha-2.0.2-ruby32.patch b/dev-ruby/mocha/files/mocha-1.16.0-ruby32.patch
index a4f6b8c2fd7a..a4f6b8c2fd7a 100644
--- a/dev-ruby/mocha/files/mocha-2.0.2-ruby32.patch
+++ b/dev-ruby/mocha/files/mocha-1.16.0-ruby32.patch
diff --git a/dev-ruby/mocha/mocha-1.16.0.ebuild b/dev-ruby/mocha/mocha-1.16.0.ebuild
index 5f825dc0d59e..ea8837619e17 100644
--- a/dev-ruby/mocha/mocha-1.16.0.ebuild
+++ b/dev-ruby/mocha/mocha-1.16.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-USE_RUBY="ruby27 ruby30 ruby31"
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
RUBY_FAKEGEM_TASK_TEST="test:units test:acceptance"
@@ -26,6 +26,10 @@ IUSE=""
ruby_add_bdepend "
test? ( >=dev-ruby/test-unit-2.5.1-r1 dev-ruby/introspection )"
+PATCHES=(
+ "${FILESDIR}"/mocha-1.16.0-ruby32.patch
+)
+
all_ruby_prepare() {
sed -i -e '/[Bb]undler/ s:^:#:' -e '1iload "lib/mocha/version.rb"' Rakefile || die
diff --git a/dev-ruby/mocha/mocha-2.0.2.ebuild b/dev-ruby/mocha/mocha-2.0.2.ebuild
index 86f55e44e1b2..7200023417c0 100644
--- a/dev-ruby/mocha/mocha-2.0.2.ebuild
+++ b/dev-ruby/mocha/mocha-2.0.2.ebuild
@@ -27,7 +27,7 @@ ruby_add_bdepend "
test? ( >=dev-ruby/test-unit-2.5.1-r1 dev-ruby/introspection )"
PATCHES=(
- "${FILESDIR}"/${P}-ruby32.patch
+ "${FILESDIR}"/${PN}-1.16.0-ruby32.patch
)
all_ruby_prepare() {