summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-11-18 20:47:57 +0100
committerHans de Graaff <graaff@gentoo.org>2024-11-18 20:48:55 +0100
commit283535940752bec69a895da8e316e890d8aee7b4 (patch)
tree9b8d5c7060b388941be0a5aa388539de0547a95a /dev-ruby
parentdev-ml/spawn: add 0.17.0 (diff)
downloadgentoo-283535940752bec69a895da8e316e890d8aee7b4.tar.gz
gentoo-283535940752bec69a895da8e316e890d8aee7b4.tar.bz2
gentoo-283535940752bec69a895da8e316e890d8aee7b4.zip
dev-ruby/sqlite3: remove pin on sqlite versions
Avoid one test failing as a result due to slightly different syntax. Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/sqlite3/sqlite3-1.7.3.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-ruby/sqlite3/sqlite3-1.7.3.ebuild b/dev-ruby/sqlite3/sqlite3-1.7.3.ebuild
index d0098c536183..92e6b3a69450 100644
--- a/dev-ruby/sqlite3/sqlite3-1.7.3.ebuild
+++ b/dev-ruby/sqlite3/sqlite3-1.7.3.ebuild
@@ -18,13 +18,13 @@ DESCRIPTION="An extension library to access a SQLite database from Ruby"
HOMEPAGE="https://github.com/sparklemotion/sqlite3-ruby"
LICENSE="BSD"
-KEYWORDS="amd64 ~arm ~arm64 ~hppa ppc ppc64 ~riscv ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ~hppa ppc ppc64 ~riscv ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
IUSE="doc test"
# We track the bundled sqlite version here
RDEPEND+=" >=dev-db/sqlite-3.45.2:3"
-DEPEND+=" >=dev-db/sqlite-3.45.2:3 <dev-db/sqlite-3.46.0"
+DEPEND+=" >=dev-db/sqlite-3.45.2:3"
ruby_add_bdepend "
doc? ( dev-ruby/rdoc )
@@ -37,6 +37,10 @@ all_ruby_prepare() {
# Remove the runtime dependency on mini_portile2. We build without
# it and it is not a runtime dependency for us.
sed -i -e '/^dependencies:/,/force_ruby_platform/d' ../metadata || die
+
+ # Avoid a failure about a specific syntax for an error, introduced with newer sqlite versions.
+ sed -e '/test_strict_mode/askip "Newer sqlite versions have different quoting"' \
+ -i test/test_database.rb || die
}
all_ruby_compile() {