summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/rubytter
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/rubytter')
-rw-r--r--dev-ruby/rubytter/Manifest1
-rw-r--r--dev-ruby/rubytter/metadata.xml8
-rw-r--r--dev-ruby/rubytter/rubytter-1.5.1.ebuild27
3 files changed, 36 insertions, 0 deletions
diff --git a/dev-ruby/rubytter/Manifest b/dev-ruby/rubytter/Manifest
new file mode 100644
index 000000000000..e9cc07fcee02
--- /dev/null
+++ b/dev-ruby/rubytter/Manifest
@@ -0,0 +1 @@
+DIST rubytter-1.5.1.gem 15872 SHA256 4444988defc185588194096ddbe313c90937e69111cd4acf4020e4f13372247c SHA512 79be7b7803a53db654a14ff83da657e3e5016d5bda61e8c127dbf6d85231a8c115d38041aba99fdabd50825135b801cc444cca84c13d174004cda8cc4760bd2e WHIRLPOOL 3587ef2c6b3397458a9d3990d635b3b695c50d30ded902689b1f764a927393e09abdccf21d2535cf11bc1f04e7d5e50a33db2f79b6e2d8702f40899c75cec2fb
diff --git a/dev-ruby/rubytter/metadata.xml b/dev-ruby/rubytter/metadata.xml
new file mode 100644
index 000000000000..61f90007fbc3
--- /dev/null
+++ b/dev-ruby/rubytter/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+<maintainer>
+ <email>naota@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-ruby/rubytter/rubytter-1.5.1.ebuild b/dev-ruby/rubytter/rubytter-1.5.1.ebuild
new file mode 100644
index 000000000000..98083347e2ff
--- /dev/null
+++ b/dev-ruby/rubytter/rubytter-1.5.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc examples/*"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Rubytter is a simple twitter library"
+HOMEPAGE="http://wiki.github.com/jugyo/rubytter"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/json-1.1.3 >=dev-ruby/oauth-0.3.6"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/d' -e '/check_dependencies/ s:^:#:' Rakefile || die
+}