summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-02-08 15:19:39 +0100
committerHans de Graaff <graaff@gentoo.org>2024-02-08 15:23:54 +0100
commit5ba727857759a812e50035accd052a5d87eb5f45 (patch)
treefdbb40b38d65d5d0f6d9eeb544070918905d961f /dev-ruby/rspec-expectations
parentdev-ruby/rspec-mocks: add 3.12.7 (diff)
downloadgentoo-5ba727857759a812e50035accd052a5d87eb5f45.tar.gz
gentoo-5ba727857759a812e50035accd052a5d87eb5f45.tar.bz2
gentoo-5ba727857759a812e50035accd052a5d87eb5f45.zip
dev-ruby/rspec-expectations: add 3.12.4
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/rspec-expectations')
-rw-r--r--dev-ruby/rspec-expectations/Manifest1
-rw-r--r--dev-ruby/rspec-expectations/rspec-expectations-3.12.4.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-ruby/rspec-expectations/Manifest b/dev-ruby/rspec-expectations/Manifest
index efed04625a37..51c552f9223e 100644
--- a/dev-ruby/rspec-expectations/Manifest
+++ b/dev-ruby/rspec-expectations/Manifest
@@ -1 +1,2 @@
DIST rspec-expectations-3.12.3-git.tgz 218754 BLAKE2B be6c6c50115bec39758f792030363de88abf5affa8a4df1161a386fee3dfb620542fca6225779e76aa2e72d1f782b65ef9db393be061e9ed47c72d96f47cf981 SHA512 37f85555e0ba16b1a76f8d59571312febfc802eab1a27ff788d57bb34f410867e753dcfee83ca3d70367b77ad9f823341c653901c8ff02c75df6863937c71315
+DIST rspec-expectations-3.12.4-git.tgz 219529 BLAKE2B 8858b586cb2b50f06c93530304ca554ddff9f3fe7078e1e2f263ab352e8315d3529bd8028b835d8b83d49bc06345a0723d2fbf31849552ef53567f2162eb503c SHA512 9317d91fb5fb02c1319010517df6f28bc117cccb3b8fd4226bd1adde00fbf13d1505be89cd036bd1849b9a142e24ec966afa536144e384700f8d11e640e2eaf9
diff --git a/dev-ruby/rspec-expectations/rspec-expectations-3.12.4.ebuild b/dev-ruby/rspec-expectations/rspec-expectations-3.12.4.ebuild
new file mode 100644
index 000000000000..96e2fb7e5b11
--- /dev/null
+++ b/dev-ruby/rspec-expectations/rspec-expectations-3.12.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
+HOMEPAGE="https://github.com/rspec/rspec-expectations"
+SRC_URI="https://github.com/rspec/${PN}/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="test"
+
+SUBVERSION="$(ver_cut 1-2)"
+
+ruby_add_rdepend ">=dev-ruby/diff-lcs-1.2.0 =dev-ruby/diff-lcs-1*
+ =dev-ruby/rspec-support-${SUBVERSION}*"
+
+ruby_add_bdepend "test? (
+ >=dev-ruby/rspec-mocks-3.2.0:3
+ >=dev-ruby/rspec-support-3.5.0:3
+ )"
+
+all_ruby_prepare() {
+ # Don't set up bundler: it doesn't understand our setup.
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+
+ # Fix minitest deprecation
+ sed -i -e 's/MiniTest/Minitest/' spec/rspec/expectations/minitest_integration_spec.rb || die
+
+ # Remove the Gemfile to avoid running through 'bundle exec'
+ rm -f Gemfile || die
+
+ # fix up the gemspecs
+ sed -i \
+ -e '/git ls/d' \
+ -e '/add_development_dependency/d' \
+ "${RUBY_FAKEGEM_GEMSPEC}" || die
+}