summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-07-18 06:33:15 +0200
committerHans de Graaff <graaff@gentoo.org>2023-07-18 06:46:41 +0200
commit37cd6a9b1f5c452dce8ea10f982d4b4acfc8d847 (patch)
treeac203d3609f63381d261940e0dc78edd621bc849 /dev-ruby/rbpdf/rbpdf-1.21.3.ebuild
parentdev-ruby/pundit: add 2.3.1 (diff)
downloadgentoo-37cd6a9b1f5c452dce8ea10f982d4b4acfc8d847.tar.gz
gentoo-37cd6a9b1f5c452dce8ea10f982d4b4acfc8d847.tar.bz2
gentoo-37cd6a9b1f5c452dce8ea10f982d4b4acfc8d847.zip
dev-ruby/rbpdf: add 1.21.3
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/rbpdf/rbpdf-1.21.3.ebuild')
-rw-r--r--dev-ruby/rbpdf/rbpdf-1.21.3.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-ruby/rbpdf/rbpdf-1.21.3.ebuild b/dev-ruby/rbpdf/rbpdf-1.21.3.ebuild
new file mode 100644
index 000000000000..62ceeefdb1f1
--- /dev/null
+++ b/dev-ruby/rbpdf/rbpdf-1.21.3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby30 ruby31 ruby32"
+
+# Avoid the complexity of the "rake" recipe and run the tests manually.
+RUBY_FAKEGEM_RECIPE_TEST=none
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby on Rails RBPDF plugin"
+HOMEPAGE="https://github.com/naitoh/rbpdf"
+SRC_URI="https://github.com/naitoh/rbpdf/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+ruby_add_bdepend "test? ( >=dev-ruby/test-unit-3 dev-ruby/webrick )"
+ruby_add_rdepend "
+ dev-ruby/actionview
+ dev-ruby/htmlentities
+ =dev-ruby/rbpdf-font-1.19*
+ || ( dev-ruby/mini_magick dev-ruby/rmagick )
+"
+
+# Two of the tests require png/jpeg support in "magick identify",
+# see bug 738784.
+BDEPEND+=" test? ( virtual/imagemagick-tools[jpeg,png] )"
+
+all_ruby_prepare() {
+ default
+
+ # This test is enabled automagically in the presence of rmagick, and
+ # then fails.
+ rm -f test/rbpdf_image_rmagick_test.rb \
+ || die "failed to remove rmagick tests"
+}
+
+each_ruby_test() {
+ local cmd='gem "test-unit", ">= 3.0"'
+ cmd+=' and '
+ cmd+='require "test/unit"'
+ cmd+=' and '
+ cmd+='Dir["test/rbpdf_*.rb"].each{|f| require("./" + f)}'
+ ${RUBY} -Ilib:.:test -e "${cmd}" || die "test suite failed"
+}