summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-07-04 07:10:39 +0200
committerHans de Graaff <graaff@gentoo.org>2022-07-04 07:10:39 +0200
commit07bd3b0780a43d837073dc725aff770d4ab195a9 (patch)
tree39118abd62ec3f399881c056839a354272126010 /dev-ruby/path_expander
parentdev-python/hatchling: Bump to 1.4.0 (diff)
downloadgentoo-07bd3b0780a43d837073dc725aff770d4ab195a9.tar.gz
gentoo-07bd3b0780a43d837073dc725aff770d4ab195a9.tar.bz2
gentoo-07bd3b0780a43d837073dc725aff770d4ab195a9.zip
dev-ruby/path_expander: add 1.1.1
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/path_expander')
-rw-r--r--dev-ruby/path_expander/Manifest1
-rw-r--r--dev-ruby/path_expander/path_expander-1.1.1.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/path_expander/Manifest b/dev-ruby/path_expander/Manifest
index 13653294f35d..c59f2ebf4c0e 100644
--- a/dev-ruby/path_expander/Manifest
+++ b/dev-ruby/path_expander/Manifest
@@ -1 +1,2 @@
DIST path_expander-1.1.0.gem 13312 BLAKE2B dca42a0e995d7ef87cef3dd26251ce378df33db557c5089b58f1130ed4c61b5521012198e381853c3583601d990aeff3a8463393e89e891b2ca9c923831ba31d SHA512 eebcd1caafba5c40512cc0c6e3419137fc169215d2eac77914419d9f3a6e200350d742b13953b2dbbdd532c9ef73e950c920017a4f178941c1e04ee832e038f7
+DIST path_expander-1.1.1.gem 13312 BLAKE2B d22b7253be821f7bf73bef48843b64356e5a4c66fb532844e4de25e9f4e01486560defda00d8cbc698a3d3b936cff742bdd3005afb32f9a41318d380d2f575cc SHA512 bd670b45bf8a265faf0ab9e845782e7bb6fa62e4360d3b5109b83b27afc54d3d372db1d0df9a098eb6935d24d29a973848c7b914b5ee0d67069ddc88c0aa79b7
diff --git a/dev-ruby/path_expander/path_expander-1.1.1.ebuild b/dev-ruby/path_expander/path_expander-1.1.1.ebuild
new file mode 100644
index 000000000000..6b828c31ed55
--- /dev/null
+++ b/dev-ruby/path_expander/path_expander-1.1.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_EXTRADOC="History.rdoc README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Pre-process CLI arguments expanding directories into their constituent files"
+HOMEPAGE="https://github.com/seattlerb/path_expander"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="1"
+IUSE=""
+
+all_ruby_prepare() {
+ # Fix tests depending on sort order
+ sed -i -e '/test_process_args_dir/,/^ end/ s:^:#:' \
+ -e '33 s/$/.sort/' \
+ -e '83 s/act/act.sort/' \
+ test/test_path_expander.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:.:test -e 'Dir["test/test_*.rb"].each{|f| require f}' || die
+}