summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-10-06 08:04:47 +0200
committerHans de Graaff <graaff@gentoo.org>2024-10-06 08:04:59 +0200
commit859f9225df1a59ae688312c7d6782fe833a035aa (patch)
tree691edb41be073bfdaeb5a101f8d07fb5f5d12420 /dev-ruby/ostruct
parentdev-ruby/rake-compiler: add 1.2.8 (diff)
downloadgentoo-859f9225df1a59ae688312c7d6782fe833a035aa.tar.gz
gentoo-859f9225df1a59ae688312c7d6782fe833a035aa.tar.bz2
gentoo-859f9225df1a59ae688312c7d6782fe833a035aa.zip
dev-ruby/ostruct: new package, add 0.6.0
Extracted from dev-lang/ruby, keeping keywords accordingly. Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/ostruct')
-rw-r--r--dev-ruby/ostruct/Manifest1
-rw-r--r--dev-ruby/ostruct/metadata.xml11
-rw-r--r--dev-ruby/ostruct/ostruct-0.6.0.ebuild28
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-ruby/ostruct/Manifest b/dev-ruby/ostruct/Manifest
new file mode 100644
index 000000000000..1870ea23e1a9
--- /dev/null
+++ b/dev-ruby/ostruct/Manifest
@@ -0,0 +1 @@
+DIST ostruct-0.6.0.tar.gz 10757 BLAKE2B 68742978efc348d28361716a18a4b9a5e23270e37a104aa3e620d3a751182f22003db467c2424025c831315a2ddb7bf4f9bb4f76b43ab612f64eb56875b55860 SHA512 34afddbc0e881432fcd143669ad182d3ddef7b2245d1429466ff893f8a419482b3fc577eea331d3edfecbe2ac831e9b3b1e5d0baa66de5528fe312afb4e2b087
diff --git a/dev-ruby/ostruct/metadata.xml b/dev-ruby/ostruct/metadata.xml
new file mode 100644
index 000000000000..206b75ea5ef2
--- /dev/null
+++ b/dev-ruby/ostruct/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ruby/ostruct</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/ostruct/ostruct-0.6.0.ebuild b/dev-ruby/ostruct/ostruct-0.6.0.ebuild
new file mode 100644
index 000000000000..2f08ed1e2061
--- /dev/null
+++ b/dev-ruby/ostruct/ostruct-0.6.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="ostruct.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Class to build custom data structures, similar to a Hash"
+HOMEPAGE="https://github.com/ruby/ostruct"
+SRC_URI="https://github.com/ruby/ostruct/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="test"
+
+ruby_add_depend "test? ( dev-ruby/test-unit dev-ruby/test-unit-ruby-core )"
+
+all_ruby_prepare() {
+ sed -e 's/__FILE__/"ostruct.gemspec"/' \
+ -e 's/__dir__/"."/' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}