summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-10-21 12:30:25 +0200
committerHans de Graaff <graaff@gentoo.org>2018-10-21 12:30:47 +0200
commit466f0d1dc2e20a4a049dcec45e492484b80ee5b2 (patch)
tree5161d83dec90b7b158f05c5dc953ba0b31355098 /dev-ruby/oauth2
parentmail-filter/bogofilter: Remove 1.2.4-r1 (diff)
downloadgentoo-466f0d1dc2e20a4a049dcec45e492484b80ee5b2.tar.gz
gentoo-466f0d1dc2e20a4a049dcec45e492484b80ee5b2.tar.bz2
gentoo-466f0d1dc2e20a4a049dcec45e492484b80ee5b2.zip
dev-ruby/oauth2: fix install without git
Closes: https://bugs.gentoo.org/669050 Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.11
Diffstat (limited to 'dev-ruby/oauth2')
-rw-r--r--dev-ruby/oauth2/oauth2-1.4.1.ebuild2
1 files changed, 2 insertions, 0 deletions
diff --git a/dev-ruby/oauth2/oauth2-1.4.1.ebuild b/dev-ruby/oauth2/oauth2-1.4.1.ebuild
index c0707ffc593e..94d54df71dd8 100644
--- a/dev-ruby/oauth2/oauth2-1.4.1.ebuild
+++ b/dev-ruby/oauth2/oauth2-1.4.1.ebuild
@@ -40,6 +40,8 @@ all_ruby_prepare() {
# Avoid spec that is too fragile in relation to ENV
sed -i -e '/outputs to $stdout when OAUTH_DEBUG=true/a skip "fragile ENV stubbing"' spec/oauth2/client_spec.rb || die
+
+ sed -i -e 's/git ls-files -z/find . -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
}
each_ruby_test() {