summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-06-17 20:32:32 +0200
committerHans de Graaff <graaff@gentoo.org>2018-06-17 20:32:57 +0200
commit569131d2001863aaf9dec9f395d0d5202cdfb7a0 (patch)
treede74ba90fa910e60655f197d10f52d6b447f0dcb /dev-ruby/net-ssh
parentx11-misc/xdg-utils: fix xdg-open with pcmanfm (diff)
downloadgentoo-569131d2001863aaf9dec9f395d0d5202cdfb7a0.tar.gz
gentoo-569131d2001863aaf9dec9f395d0d5202cdfb7a0.tar.bz2
gentoo-569131d2001863aaf9dec9f395d0d5202cdfb7a0.zip
dev-ruby/net-ssh: fix tests with USE=-sodium
Don't try to run tests that depend on libsodium in this case. Closes: https://bugs.gentoo.org/647334 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-ruby/net-ssh')
-rw-r--r--dev-ruby/net-ssh/net-ssh-4.2.0.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/dev-ruby/net-ssh/net-ssh-4.2.0.ebuild b/dev-ruby/net-ssh/net-ssh-4.2.0.ebuild
index cd46a77e129a..6d01274e11ab 100644
--- a/dev-ruby/net-ssh/net-ssh-4.2.0.ebuild
+++ b/dev-ruby/net-ssh/net-ssh-4.2.0.ebuild
@@ -27,6 +27,11 @@ all_ruby_prepare() {
# Don't use a ruby-bundled version of libsodium
sed -i -e '/rbnacl\/libsodium/ s:^:#:' lib/net/ssh/authentication/ed25519.rb || die
+ # Don' try to use libsodium-related tests with USE=-sodium
+ if ! use sodium ; then
+ rm -f test/authentication/test_ed25519.rb
+ fi
+
# Avoid bundler dependency
sed -i -e '/\(bundler\|:release\)/ s:^:#:' Rakefile || die
}