summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-05-08 07:05:48 +0200
committerHans de Graaff <graaff@gentoo.org>2024-05-08 07:06:28 +0200
commitcec52c8314929f3fa41770f2ce46af5b8cefb2b4 (patch)
tree741fc600f5c0e5436ef1ae1942c9061ae164ef15 /dev-ruby/multipart-post/multipart-post-2.4.1.ebuild
parentdev-ruby/multi_xml: add 0.7.1 (diff)
downloadgentoo-cec52c8314929f3fa41770f2ce46af5b8cefb2b4.tar.gz
gentoo-cec52c8314929f3fa41770f2ce46af5b8cefb2b4.tar.bz2
gentoo-cec52c8314929f3fa41770f2ce46af5b8cefb2b4.zip
dev-ruby/multipart-post: add 2.4.1
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/multipart-post/multipart-post-2.4.1.ebuild')
-rw-r--r--dev-ruby/multipart-post/multipart-post-2.4.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/multipart-post/multipart-post-2.4.1.ebuild b/dev-ruby/multipart-post/multipart-post-2.4.1.ebuild
new file mode 100644
index 000000000000..15834224ce07
--- /dev/null
+++ b/dev-ruby/multipart-post/multipart-post-2.4.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="changelog.md readme.md"
+RUBY_FAKEGEM_GEMSPEC="multipart-post.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Adds a streamy multipart form post capability to Net::HTTP"
+HOMEPAGE="https://github.com/socketry/multipart-post"
+SRC_URI="https://github.com/socketry/multipart-post/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+
+all_ruby_prepare() {
+ sed -i -e '/\(bundler\|covered\)/ s:^:#:' spec/spec_helper.rb || die
+
+ sed -i -e 's:_relative ":"./:' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Remove warnings since these are only actionable for developers,
+ # not for people consuming this package as part of other tools.
+ sed -i -e '/Top level/ s/warn/# warn/' lib/*.rb || die
+}