summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-12-16 08:58:22 +0100
committerHans de Graaff <graaff@gentoo.org>2023-12-16 08:58:39 +0100
commit90aaaf36545243b265eed3178cce832aa7e7b1a0 (patch)
treefdc5bc9fa76132cddb5d265cc547e4e7de379694 /dev-ruby/ipaddr/ipaddr-1.2.6.ebuild
parentdev-ruby/securerandom: add 0.3.1 (diff)
downloadgentoo-90aaaf36545243b265eed3178cce832aa7e7b1a0.tar.gz
gentoo-90aaaf36545243b265eed3178cce832aa7e7b1a0.tar.bz2
gentoo-90aaaf36545243b265eed3178cce832aa7e7b1a0.zip
dev-ruby/ipaddr: add 1.2.6
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/ipaddr/ipaddr-1.2.6.ebuild')
-rw-r--r--dev-ruby/ipaddr/ipaddr-1.2.6.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/ipaddr/ipaddr-1.2.6.ebuild b/dev-ruby/ipaddr/ipaddr-1.2.6.ebuild
new file mode 100644
index 000000000000..26d3d46e7b6f
--- /dev/null
+++ b/dev-ruby/ipaddr/ipaddr-1.2.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="ipaddr.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="IPAddr provides a set of methods to manipulate an IPv4 or IPv6 address"
+HOMEPAGE="https://github.com/ruby/ipaddr"
+SRC_URI="https://github.com/ruby/ipaddr/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -e 's/__dir__/"."/' \
+ -e 's/__FILE__/"'${RUBY_FAKEGEM_GEMSPEC}'"/' \
+ -e 's/git ls-files -z/find * -print0/' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:.:test:test/lib -rhelper -e 'Dir["test/**/test_*.rb"].each{|f| require f}' || die
+}