summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/html2haml
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/html2haml')
-rw-r--r--dev-ruby/html2haml/Manifest1
-rw-r--r--dev-ruby/html2haml/html2haml-2.0.0.ebuild35
-rw-r--r--dev-ruby/html2haml/metadata.xml8
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-ruby/html2haml/Manifest b/dev-ruby/html2haml/Manifest
new file mode 100644
index 000000000000..e62d966dd69d
--- /dev/null
+++ b/dev-ruby/html2haml/Manifest
@@ -0,0 +1 @@
+DIST html2haml-2.0.0.gem 20992 SHA256 91345409d56f3d86d927fd2d8b665ec9b896757928ae8a898520804c91673f19 SHA512 d888a84432486a143dd6f3947ce6d83a043d3fd19bdab5f06d990bd689d85b8d683ce6c4796902d264cf6e1b400b246e94191d6ddf03f5d98b27ee054f6a4006 WHIRLPOOL 2fd7bfc5ac27f01114e81c0cd73e4c90cc82b65d5e6e52ad137d71d60b3548273a80e46e5af527dc3a89c8a64e2b6605ad79d88f4169f78aa431593be449889b
diff --git a/dev-ruby/html2haml/html2haml-2.0.0.ebuild b/dev-ruby/html2haml/html2haml-2.0.0.ebuild
new file mode 100644
index 000000000000..071521009a84
--- /dev/null
+++ b/dev-ruby/html2haml/html2haml-2.0.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+RUBY_FAKEGEM_EXTRADOC="README.md Changelog.markdown"
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Convert HTML and HTML+Erb to Haml"
+HOMEPAGE="https://github.com/haml/html2haml"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/nokogiri-1.6.0
+ >=dev-ruby/erubis-2.7.0
+ >=dev-ruby/ruby_parser-3.5
+ >=dev-ruby/haml-4.0.0"
+
+ruby_add_bdepend "test? ( dev-ruby/minitest:0 )"
+
+all_ruby_prepare() {
+ sed -i -e "/bundler/d" test/test_helper.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test test/html2haml_test.rb || die
+ ${RUBY} -Ilib:test test/erb_test.rb || die
+}
diff --git a/dev-ruby/html2haml/metadata.xml b/dev-ruby/html2haml/metadata.xml
new file mode 100644
index 000000000000..eafe596330df
--- /dev/null
+++ b/dev-ruby/html2haml/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">haml/html2haml</remote-id>
+ </upstream>
+</pkgmetadata>