summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2022-07-07 12:20:24 +0200
committerAlexis Ballier <aballier@gentoo.org>2022-07-07 12:27:25 +0200
commite4d0be42d3021ba5d1a2c3a0dabcfff2e5a17b0d (patch)
tree848182ee0053cb7106652f07d74ab4a4aca1f58b /dev-ros
parentros-meta/vision_visp: Bump to 0.13.1. (diff)
downloadgentoo-e4d0be42d3021ba5d1a2c3a0dabcfff2e5a17b0d.tar.gz
gentoo-e4d0be42d3021ba5d1a2c3a0dabcfff2e5a17b0d.tar.bz2
gentoo-e4d0be42d3021ba5d1a2c3a0dabcfff2e5a17b0d.zip
dev-ros/visp_tracker: fix build
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/visp_tracker/visp_tracker-0.13.1.ebuild5
-rw-r--r--dev-ros/visp_tracker/visp_tracker-9999.ebuild7
2 files changed, 11 insertions, 1 deletions
diff --git a/dev-ros/visp_tracker/visp_tracker-0.13.1.ebuild b/dev-ros/visp_tracker/visp_tracker-0.13.1.ebuild
index 5a0b0f5e491f..e0d68f493025 100644
--- a/dev-ros/visp_tracker/visp_tracker-0.13.1.ebuild
+++ b/dev-ros/visp_tracker/visp_tracker-0.13.1.ebuild
@@ -37,3 +37,8 @@ if [ "${PV#9999}" = "${PV}" ] ; then
S="${WORKDIR}/vision_visp-noetic-${PV}/${ROS_SUBDIR}"
fi
PATCHES=( "${FILESDIR}/gcc6.patch" )
+
+src_compile() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ ros-catkin_src_compile
+}
diff --git a/dev-ros/visp_tracker/visp_tracker-9999.ebuild b/dev-ros/visp_tracker/visp_tracker-9999.ebuild
index 81537d67935a..e0d68f493025 100644
--- a/dev-ros/visp_tracker/visp_tracker-9999.ebuild
+++ b/dev-ros/visp_tracker/visp_tracker-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -37,3 +37,8 @@ if [ "${PV#9999}" = "${PV}" ] ; then
S="${WORKDIR}/vision_visp-noetic-${PV}/${ROS_SUBDIR}"
fi
PATCHES=( "${FILESDIR}/gcc6.patch" )
+
+src_compile() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ ros-catkin_src_compile
+}