summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-09-24 13:15:59 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-09-24 13:29:47 +0300
commitd6cfdbac7f993a5f60829816e47722251bedeb14 (patch)
tree00a582b0b48ace5c6d50fae0781c1816e923717e /dev-ros
parentdev-ros/ament_cmake_cpplint: enable py3.9, enable py3.10 (diff)
downloadgentoo-d6cfdbac7f993a5f60829816e47722251bedeb14.tar.gz
gentoo-d6cfdbac7f993a5f60829816e47722251bedeb14.tar.bz2
gentoo-d6cfdbac7f993a5f60829816e47722251bedeb14.zip
dev-ros/ament_lint_auto: enable py3.9, enable py3.10
tested by checking reverse dependencies are building the same and passing Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/ament_lint_auto/ament_lint_auto-0.11.2.ebuild16
-rw-r--r--dev-ros/ament_lint_auto/ament_lint_auto-9999.ebuild16
2 files changed, 12 insertions, 20 deletions
diff --git a/dev-ros/ament_lint_auto/ament_lint_auto-0.11.2.ebuild b/dev-ros/ament_lint_auto/ament_lint_auto-0.11.2.ebuild
index 99bd8c66a9d9..7c0ae86f0a35 100644
--- a/dev-ros/ament_lint_auto/ament_lint_auto-0.11.2.ebuild
+++ b/dev-ros/ament_lint_auto/ament_lint_auto-0.11.2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python{3_7,3_8} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit cmake python-any-r1
@@ -11,11 +11,11 @@ ROS_PN="ament_lint"
if [ "${PV#9999}" != "${PV}" ] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/ament/ament_lint"
- SRC_URI=""
- S=${WORKDIR}/${P}/${PN}
+ S="${WORKDIR}/${P}/${PN}"
else
SRC_URI="https://github.com/ament/ament_lint/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+ KEYWORDS="~amd64"
fi
DESCRIPTION="The auto-magic functions for ease to use of the ament linters"
@@ -23,12 +23,6 @@ HOMEPAGE="https://github.com/ament/ament_lint"
LICENSE="Apache-2.0"
SLOT="0"
-if [ "${PV#9999}" != "${PV}" ] ; then
- PROPERTIES="live"
-else
- KEYWORDS="~amd64"
-fi
-IUSE=""
RDEPEND="
dev-ros/ament_cmake_core
@@ -37,7 +31,9 @@ RDEPEND="
DEPEND="${RDEPEND}"
# Deps here are transitive from ament_cmake_core to have matching python support
BDEPEND="
- $(python_gen_any_dep 'dev-python/ament_package[${PYTHON_USEDEP}] dev-python/catkin_pkg[${PYTHON_USEDEP}]')
+ $(python_gen_any_dep '
+ dev-python/ament_package[${PYTHON_USEDEP}]
+ dev-python/catkin_pkg[${PYTHON_USEDEP}]')
${PYTHON_DEPS}
"
diff --git a/dev-ros/ament_lint_auto/ament_lint_auto-9999.ebuild b/dev-ros/ament_lint_auto/ament_lint_auto-9999.ebuild
index 99bd8c66a9d9..7c0ae86f0a35 100644
--- a/dev-ros/ament_lint_auto/ament_lint_auto-9999.ebuild
+++ b/dev-ros/ament_lint_auto/ament_lint_auto-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python{3_7,3_8} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit cmake python-any-r1
@@ -11,11 +11,11 @@ ROS_PN="ament_lint"
if [ "${PV#9999}" != "${PV}" ] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/ament/ament_lint"
- SRC_URI=""
- S=${WORKDIR}/${P}/${PN}
+ S="${WORKDIR}/${P}/${PN}"
else
SRC_URI="https://github.com/ament/ament_lint/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+ KEYWORDS="~amd64"
fi
DESCRIPTION="The auto-magic functions for ease to use of the ament linters"
@@ -23,12 +23,6 @@ HOMEPAGE="https://github.com/ament/ament_lint"
LICENSE="Apache-2.0"
SLOT="0"
-if [ "${PV#9999}" != "${PV}" ] ; then
- PROPERTIES="live"
-else
- KEYWORDS="~amd64"
-fi
-IUSE=""
RDEPEND="
dev-ros/ament_cmake_core
@@ -37,7 +31,9 @@ RDEPEND="
DEPEND="${RDEPEND}"
# Deps here are transitive from ament_cmake_core to have matching python support
BDEPEND="
- $(python_gen_any_dep 'dev-python/ament_package[${PYTHON_USEDEP}] dev-python/catkin_pkg[${PYTHON_USEDEP}]')
+ $(python_gen_any_dep '
+ dev-python/ament_package[${PYTHON_USEDEP}]
+ dev-python/catkin_pkg[${PYTHON_USEDEP}]')
${PYTHON_DEPS}
"