summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2021-01-05 20:45:57 +0100
committerAlexis Ballier <aballier@gentoo.org>2021-01-05 21:02:55 +0100
commit56ef4fb97d6898584105fded612212f2e531cc08 (patch)
tree724ba6f861f4b7366208160132276b870017ba63 /dev-ros
parentros-meta/ros_control: Bump to 0.19.4. (diff)
downloadgentoo-56ef4fb97d6898584105fded612212f2e531cc08.tar.gz
gentoo-56ef4fb97d6898584105fded612212f2e531cc08.tar.bz2
gentoo-56ef4fb97d6898584105fded612212f2e531cc08.zip
dev-ros/hector_compressed_map_transport: Bump to 0.5.0.
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/hector_compressed_map_transport/Manifest1
-rw-r--r--dev-ros/hector_compressed_map_transport/hector_compressed_map_transport-0.5.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-ros/hector_compressed_map_transport/Manifest b/dev-ros/hector_compressed_map_transport/Manifest
index 703025b72310..c13922877575 100644
--- a/dev-ros/hector_compressed_map_transport/Manifest
+++ b/dev-ros/hector_compressed_map_transport/Manifest
@@ -1 +1,2 @@
DIST hector_slam-0.4.1.tar.gz 66772 BLAKE2B ad6f5596ea1fca2ed68017534280a4d622179de8df4c039e95f3e87a0e591212944d65e4d507194eb33584f7f55cba4fe398b19f5a22bfb3afce1b2406d1635d SHA512 bd0932971114f13c41c6e346756f2c95cc0a9a011d11202792a6f837757a144355e05c3e7ed1afa574b743166a78f1a7855c5693b0c57378611e50c386c2483e
+DIST hector_slam-0.5.0.tar.gz 160320 BLAKE2B 9109b81740296aada8b0987d153774ac547cf063546973e8034849a5c81117c10047c12ca65f15feae5355c35a6e746cbf0ab8fa2089d282beb1f7aa06528254 SHA512 d9d7e0e7de96330358bcd98de2083ee67e0d232d6758599291607951696aef5dd93b335252448ddec59202627f69fd5a9122c0f3a2829744b4b6417906aab3ed
diff --git a/dev-ros/hector_compressed_map_transport/hector_compressed_map_transport-0.5.0.ebuild b/dev-ros/hector_compressed_map_transport/hector_compressed_map_transport-0.5.0.ebuild
new file mode 100644
index 000000000000..b17d75bdeaca
--- /dev/null
+++ b/dev-ros/hector_compressed_map_transport/hector_compressed_map_transport-0.5.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_slam"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Means for transporting compressed map data through the use of image_transport"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cv_bridge
+ media-libs/opencv:=
+ dev-ros/hector_map_tools
+ dev-ros/image_transport
+ media-libs/opencv
+"
+DEPEND="${RDEPEND}
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-cpp/eigen:3"