summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-22 18:33:44 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-22 19:04:21 +0200
commit76ad242afe25bd1cbc78e29da6759490065a104b (patch)
treea7604e257b3b31114b11b0e520c41190f556ef9a /dev-ros/tf2_ros/tf2_ros-9999.ebuild
parentdev-ros/tf2_py: Initial import. Ebuild by me. (diff)
downloadgentoo-76ad242afe25bd1cbc78e29da6759490065a104b.tar.gz
gentoo-76ad242afe25bd1cbc78e29da6759490065a104b.tar.bz2
gentoo-76ad242afe25bd1cbc78e29da6759490065a104b.zip
dev-ros/tf2_ros: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/tf2_ros/tf2_ros-9999.ebuild')
-rw-r--r--dev-ros/tf2_ros/tf2_ros-9999.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ros/tf2_ros/tf2_ros-9999.ebuild b/dev-ros/tf2_ros/tf2_ros-9999.ebuild
new file mode 100644
index 000000000000..248dddf79d08
--- /dev/null
+++ b/dev-ros/tf2_ros/tf2_ros-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/geometry_experimental"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="ROS bindings for the tf2 library, for both Python and C++"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/actionlib[${PYTHON_USEDEP}]
+ dev-ros/message_filters
+ dev-ros/roscpp
+ dev-ros/rosgraph
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/tf2
+ dev-ros/tf2_py[${PYTHON_USEDEP}]
+ dev-ros/actionlib_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP},${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf2_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP},${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"