summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-05-12 12:56:05 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-05-12 13:13:29 +0200
commitd3b3024e9060955bb47c8d3ef7e0fcab07d415aa (patch)
tree539bcac8a7c8d3f220f3be8e2b1ffac2803516f0 /dev-ros/tf/tf-1.12.0.ebuild
parentdev-ros/kdl_conversions: Bump to 1.12.0. (diff)
downloadgentoo-d3b3024e9060955bb47c8d3ef7e0fcab07d415aa.tar.gz
gentoo-d3b3024e9060955bb47c8d3ef7e0fcab07d415aa.tar.bz2
gentoo-d3b3024e9060955bb47c8d3ef7e0fcab07d415aa.zip
dev-ros/tf: Bump to 1.12.0.
Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'dev-ros/tf/tf-1.12.0.ebuild')
-rw-r--r--dev-ros/tf/tf-1.12.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-ros/tf/tf-1.12.0.ebuild b/dev-ros/tf/tf-1.12.0.ebuild
new file mode 100644
index 000000000000..d129d24ee28a
--- /dev/null
+++ b/dev-ros/tf/tf-1.12.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/ros/geometry"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Maintains the relationship between coordinate frames in a tree structure buffered in time"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=[threads]
+ dev-ros/angles
+ dev-ros/message_filters
+ dev-ros/rosconsole
+ dev-ros/rostime
+ dev-ros/roscpp
+ dev-ros/tf2_ros
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-cpp/gtest
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"