summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-01-23 13:18:39 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-01-23 13:28:11 +0100
commitcc716230890e07a3aae7628a12e53f4cc1bfc0b0 (patch)
tree4359a4047ded5793aa014719614e24d60d1cb638 /dev-ros/stereo_image_proc
parentsys-kernel/gentoo-sources: Linux kernel 4.4.44 (diff)
downloadgentoo-cc716230890e07a3aae7628a12e53f4cc1bfc0b0.tar.gz
gentoo-cc716230890e07a3aae7628a12e53f4cc1bfc0b0.tar.bz2
gentoo-cc716230890e07a3aae7628a12e53f4cc1bfc0b0.zip
dev-ros/stereo_image_proc: Backport upstream patch to build with gcc6.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ros/stereo_image_proc')
-rw-r--r--dev-ros/stereo_image_proc/files/gcc6.patch33
-rw-r--r--dev-ros/stereo_image_proc/stereo_image_proc-1.12.19-r1.ebuild3
2 files changed, 35 insertions, 1 deletions
diff --git a/dev-ros/stereo_image_proc/files/gcc6.patch b/dev-ros/stereo_image_proc/files/gcc6.patch
new file mode 100644
index 000000000000..ee4dfdaa8d30
--- /dev/null
+++ b/dev-ros/stereo_image_proc/files/gcc6.patch
@@ -0,0 +1,33 @@
+commit 6c2d65452bd5fe62723988a1a570789921900d59
+Author: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
+Date: Fri Sep 30 15:39:47 2016 +0200
+
+ address gcc6 build error
+
+ With gcc6, compiling fails with `stdlib.h: No such file or directory`,
+ as including '-isystem /usr/include' breaks with gcc6, cf.,
+ https://gcc.gnu.org/bugzilla/show_bug.cgi?id=70129.
+
+ This commit addresses this issue for this package in the same way
+ it was addressed in various other ROS packages. A list of related
+ commits and pull requests is at:
+
+ https://github.com/ros/rosdistro/issues/12783
+
+ Signed-off-by: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
+
+diff --git a/stereo_image_proc/CMakeLists.txt b/stereo_image_proc/CMakeLists.txt
+index b7127d2..e201436 100644
+--- a/stereo_image_proc/CMakeLists.txt
++++ b/stereo_image_proc/CMakeLists.txt
+@@ -16,9 +16,7 @@ catkin_package(
+ include_directories(include)
+
+ find_package(OpenCV REQUIRED)
+-include_directories(SYSTEM ${catkin_INCLUDE_DIRS}
+- ${OpenCV_INCLUDE_DIRS}
+-)
++include_directories(${catkin_INCLUDE_DIRS} ${OpenCV_INCLUDE_DIRS})
+
+ # Nodelet library
+ add_library(${PROJECT_NAME} src/libstereo_image_proc/processor.cpp src/nodelets/disparity.cpp src/nodelets/point_cloud2.cpp)
diff --git a/dev-ros/stereo_image_proc/stereo_image_proc-1.12.19-r1.ebuild b/dev-ros/stereo_image_proc/stereo_image_proc-1.12.19-r1.ebuild
index a180aaa9d27a..b01571e90467 100644
--- a/dev-ros/stereo_image_proc/stereo_image_proc-1.12.19-r1.ebuild
+++ b/dev-ros/stereo_image_proc/stereo_image_proc-1.12.19-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -29,3 +29,4 @@ RDEPEND="
dev-libs/boost:=[threads]
"
DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/gcc6.patch" )