summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-25 07:54:40 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-25 08:40:09 +0200
commit15db0414475ad777b905fca826e6a7fb02d2a960 (patch)
tree706307914d5baf6031fad22fada1b90c14ac89b5 /dev-ros/rqt_reconfigure
parentdev-ros/rqt_reconfigure: remove old (diff)
downloadgentoo-15db0414475ad777b905fca826e6a7fb02d2a960.tar.gz
gentoo-15db0414475ad777b905fca826e6a7fb02d2a960.tar.bz2
gentoo-15db0414475ad777b905fca826e6a7fb02d2a960.zip
dev-ros/rqt_reconfigure: bump to 0.4.8 and update to split repos
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ros/rqt_reconfigure')
-rw-r--r--dev-ros/rqt_reconfigure/Manifest1
-rw-r--r--dev-ros/rqt_reconfigure/metadata.xml2
-rw-r--r--dev-ros/rqt_reconfigure/rqt_reconfigure-0.4.8.ebuild25
-rw-r--r--dev-ros/rqt_reconfigure/rqt_reconfigure-9999.ebuild5
4 files changed, 29 insertions, 4 deletions
diff --git a/dev-ros/rqt_reconfigure/Manifest b/dev-ros/rqt_reconfigure/Manifest
index 7bb8c4d74093..d9885f6c890b 100644
--- a/dev-ros/rqt_reconfigure/Manifest
+++ b/dev-ros/rqt_reconfigure/Manifest
@@ -1 +1,2 @@
DIST rqt_common_plugins-0.4.7.tar.gz 246977 SHA256 83153ad89c67551c3fb4f36cad7f056d90c559958ac80203e2aa4605beb49a7f SHA512 eb10a7c03bb079d939a9705a08e9194c83e020235a13ed2d4ff8e9c3c73e5abbd0a9bd7c00587135767497b155bb9516d7b4c2240fbe2118d7b0668d6ee32ab7 WHIRLPOOL b002f836ee0f5ea213ec31be8e59910c7c3c9508301389309e60eeb7dd35989ae4e4dfa5fa9ee592371f05e6cd842a6e3b0ccd6ac4ed7a9efd8d60c36b1e6d65
+DIST rqt_reconfigure-0.4.8.tar.gz 27937 SHA256 78aef9e2317c425a7e9ed45b622d9f866d98ca3b95fca8841fa8e42293f29b53 SHA512 0ed02c9429974cfb598371923440dfa3b2ea00018898bb404f0301d1573d6162f61c7628edbf2b9517a9104d8dfbc63f31257a58ad3abf859165231159f794d2 WHIRLPOOL 84b8c340f25fcba31dfb2686965720805e9f7038d2648d96a61706bacd8658729bb3dffece8b3ee9e0f00c3374f80b2cc2a47017f9aaf0234286602906627da2
diff --git a/dev-ros/rqt_reconfigure/metadata.xml b/dev-ros/rqt_reconfigure/metadata.xml
index cb473d142b8e..9d3b88bc3b9c 100644
--- a/dev-ros/rqt_reconfigure/metadata.xml
+++ b/dev-ros/rqt_reconfigure/metadata.xml
@@ -6,6 +6,6 @@
<name>Gentoo ROS Project</name>
</maintainer>
<upstream>
- <remote-id type="github">ros-visualization/rqt_common_plugins</remote-id>
+ <remote-id type="github">ros-visualization/rqt_reconfigure</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-ros/rqt_reconfigure/rqt_reconfigure-0.4.8.ebuild b/dev-ros/rqt_reconfigure/rqt_reconfigure-0.4.8.ebuild
new file mode 100644
index 000000000000..990d0892323d
--- /dev/null
+++ b/dev-ros/rqt_reconfigure/rqt_reconfigure-0.4.8.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_reconfigure"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Provides the way to view and edit the parameters that are accessible via dynamic_reconfigure"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rqt_console[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+ dev-ros/rqt_py_common[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/rqt_reconfigure/rqt_reconfigure-9999.ebuild b/dev-ros/rqt_reconfigure/rqt_reconfigure-9999.ebuild
index e9f8fd72dccc..990d0892323d 100644
--- a/dev-ros/rqt_reconfigure/rqt_reconfigure-9999.ebuild
+++ b/dev-ros/rqt_reconfigure/rqt_reconfigure-9999.ebuild
@@ -1,12 +1,11 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
KEYWORDS="~amd64"
-ROS_REPO_URI="https://github.com/ros-visualization/rqt_common_plugins"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_reconfigure"
PYTHON_COMPAT=( python2_7 )
-ROS_SUBDIR=${PN}
inherit ros-catkin