summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2021-08-03 13:45:04 +0200
committerAlexis Ballier <aballier@gentoo.org>2021-08-03 13:56:45 +0200
commit2d36e7363e7dcf404a055660dc6cef49918ed6dc (patch)
tree2971fdfbae815f9e9979152f2be11b5e1e2766f6 /dev-ros/rosserial_python/rosserial_python-0.9.2.ebuild
parentdev-ros/rosserial_msgs: Bump to 0.9.2. (diff)
downloadgentoo-2d36e7363e7dcf404a055660dc6cef49918ed6dc.tar.gz
gentoo-2d36e7363e7dcf404a055660dc6cef49918ed6dc.tar.bz2
gentoo-2d36e7363e7dcf404a055660dc6cef49918ed6dc.zip
dev-ros/rosserial_python: Bump to 0.9.2.
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rosserial_python/rosserial_python-0.9.2.ebuild')
-rw-r--r--dev-ros/rosserial_python/rosserial_python-0.9.2.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ros/rosserial_python/rosserial_python-0.9.2.ebuild b/dev-ros/rosserial_python/rosserial_python-0.9.2.ebuild
new file mode 100644
index 000000000000..29c26a180d10
--- /dev/null
+++ b/dev-ros/rosserial_python/rosserial_python-0.9.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros-drivers/rosserial"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="A Python-based implementation of the ROS serial protocol"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep "dev-python/pyserial[\${PYTHON_USEDEP}]")
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rosserial_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"