summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-23 12:07:05 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-23 12:12:07 +0200
commit2c435247e23d9ca4ca497af1145ce711cd60d3f2 (patch)
tree8a3ab2345a29fdf5f41ddc70174ee5661d8d1e90 /dev-ros/qt_dotgraph/qt_dotgraph-9999.ebuild
parentdev-ros/qt_gui_py_common: Initial import. Ebuild by me. (diff)
downloadgentoo-2c435247e23d9ca4ca497af1145ce711cd60d3f2.tar.gz
gentoo-2c435247e23d9ca4ca497af1145ce711cd60d3f2.tar.bz2
gentoo-2c435247e23d9ca4ca497af1145ce711cd60d3f2.zip
dev-ros/qt_dotgraph: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/qt_dotgraph/qt_dotgraph-9999.ebuild')
-rw-r--r--dev-ros/qt_dotgraph/qt_dotgraph-9999.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ros/qt_dotgraph/qt_dotgraph-9999.ebuild b/dev-ros/qt_dotgraph/qt_dotgraph-9999.ebuild
new file mode 100644
index 000000000000..c76b5bca024e
--- /dev/null
+++ b/dev-ros/qt_dotgraph/qt_dotgraph-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/qt_gui_core"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Helpers to work with dot graphs"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ media-gfx/pydot[${PYTHON_USEDEP}]
+ dev-ros/python_qt_binding[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pygraphviz[${PYTHON_USEDEP}]
+ )"