summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-16 17:41:50 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-16 18:30:50 +0200
commit306b8e2592aaa9f8359bcf61728b443d61dedaf1 (patch)
tree9f149bc2391ef2136f8b0ee0eb7b18d4d259a12c /dev-ros/mavlink-gbp-release/mavlink-gbp-release-2020.7.7.ebuild
parentsci-geosciences/GeographicLib: initial import (diff)
downloadgentoo-306b8e2592aaa9f8359bcf61728b443d61dedaf1.tar.gz
gentoo-306b8e2592aaa9f8359bcf61728b443d61dedaf1.tar.bz2
gentoo-306b8e2592aaa9f8359bcf61728b443d61dedaf1.zip
dev-ros/mavlink-gbp-release: bump to 2020.7.7
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/mavlink-gbp-release/mavlink-gbp-release-2020.7.7.ebuild')
-rw-r--r--dev-ros/mavlink-gbp-release/mavlink-gbp-release-2020.7.7.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ros/mavlink-gbp-release/mavlink-gbp-release-2020.7.7.ebuild b/dev-ros/mavlink-gbp-release/mavlink-gbp-release-2020.7.7.ebuild
new file mode 100644
index 000000000000..b80138befc6b
--- /dev/null
+++ b/dev-ros/mavlink-gbp-release/mavlink-gbp-release-2020.7.7.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/mavlink/mavlink-gbp-release"
+EGIT_BRANCH="release/noetic/mavlink"
+VER_PREFIX="${EGIT_BRANCH}/"
+VER_SUFFIX=-${PV#*_p}
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="MAVLink message marshaling library"
+LICENSE="LGPL-3"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-python/future[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+S="${WORKDIR}/${PN}-${EGIT_BRANCH//\//-}"
+PATCHES=( "${FILESDIR}/gentoo.patch" )
+
+src_configure() {
+ export ROS_PYTHON_VERSION=3.6
+ ros-catkin_src_configure
+}