summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-23 14:15:33 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-23 17:18:51 +0200
commit563ebf9e9eddd84ad3ad37aae4847bc20bd11351 (patch)
treee4b812c722c6d68710aff2aca5538c0f7d652cad /dev-ros/ament_lint_auto/ament_lint_auto-9999.ebuild
parentdev-libs/console_bridge: Remove old (diff)
downloadgentoo-563ebf9e9eddd84ad3ad37aae4847bc20bd11351.tar.gz
gentoo-563ebf9e9eddd84ad3ad37aae4847bc20bd11351.tar.bz2
gentoo-563ebf9e9eddd84ad3ad37aae4847bc20bd11351.zip
dev-ros/ament_lint_auto: initial import
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/ament_lint_auto/ament_lint_auto-9999.ebuild')
-rw-r--r--dev-ros/ament_lint_auto/ament_lint_auto-9999.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-ros/ament_lint_auto/ament_lint_auto-9999.ebuild b/dev-ros/ament_lint_auto/ament_lint_auto-9999.ebuild
new file mode 100644
index 000000000000..120c90db0dd4
--- /dev/null
+++ b/dev-ros/ament_lint_auto/ament_lint_auto-9999.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+
+inherit cmake python-any-r1
+
+ROS_PN="ament_lint"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ament/ament_lint"
+ SRC_URI=""
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/ament/ament_lint/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
+ S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+fi
+
+DESCRIPTION="The auto-magic functions for ease to use of the ament linters"
+HOMEPAGE="https://github.com/ament/ament_lint"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+IUSE=""
+
+RDEPEND="
+ dev-ros/ament_cmake_core
+ dev-ros/ament_cmake_test
+"
+DEPEND="${RDEPEND}"
+# Deps here are transitive from ament_cmake_core to have matching python support
+BDEPEND="
+ $(python_gen_any_dep 'dev-python/ament_package[${PYTHON_USEDEP}] dev-python/catkin_pkg[${PYTHON_USEDEP}]')
+ ${PYTHON_DEPS}
+"
+
+python_check_deps() {
+ has_version "dev-python/ament_package[${PYTHON_USEDEP}]" && \
+ has_version "dev-python/catkin_pkg[${PYTHON_USEDEP}]"
+}