summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-04-13 23:12:17 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-04-13 23:44:24 +0200
commit408acd0af4b9266906dc6245cb61983e32a865bf (patch)
treee5147369f87ccc65ea2031fec01a424d57cb454f /dev-qt/qtpaths
parentdev-qt/qtopengl: 5.15.9 version bump (diff)
downloadgentoo-408acd0af4b9266906dc6245cb61983e32a865bf.tar.gz
gentoo-408acd0af4b9266906dc6245cb61983e32a865bf.tar.bz2
gentoo-408acd0af4b9266906dc6245cb61983e32a865bf.zip
dev-qt/qtpaths: 5.15.9 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt/qtpaths')
-rw-r--r--dev-qt/qtpaths/Manifest2
-rw-r--r--dev-qt/qtpaths/qtpaths-5.15.9.ebuild28
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-qt/qtpaths/Manifest b/dev-qt/qtpaths/Manifest
index 30c17d5392c7..17422b605ad1 100644
--- a/dev-qt/qtpaths/Manifest
+++ b/dev-qt/qtpaths/Manifest
@@ -1,2 +1,4 @@
DIST qttools-5.15.8-gentoo-kde-1.tar.xz 1020 BLAKE2B 1585a66678f318e38b50b17a52f3efd1b53c9c13ceaf63a21fb532ad55790d1f8a5829a10d064de0a7d6efce47bc672916c580b5222f43c35f7869371fc91857 SHA512 e1333e15b1d2f546f6c2164a7da0ef684c024cfa48b847d5671716fa789fdab7e1ed50f3be6efe09e56578c62dd6029aa1fa1546d34b53bba9894445b58aa860
+DIST qttools-5.15.9-gentoo-kde-1.tar.xz 1024 BLAKE2B cc4cf05962b9d29aeb34f18df530073f051945b8922dea8a5e43d8337bf442d7e7e148aaa68912a9df481fed0617e3568cd80a2e07359afc1b5228d08ca0d6cb SHA512 9781fbc9f10e389d0094a756ac63679bd4fd24e6809e486669a0236c2f8e0fe1285985a936867f47d309162b57c886d48fb5075445e1a51de20a2916b09a8a89
DIST qttools-everywhere-opensource-src-5.15.8.tar.xz 8898368 BLAKE2B ea99e5bdf86d6d48fabd45bf55a48e5604d1a1e938a12838d3a928449d41354c4986401e7f159718432004f7357e28c88d7939f32bc2942bda1cb3abb8e28c33 SHA512 1248b61e21d1bab30c6f8380af0b83ffd2c5f4e75b2906f561f8aae3a8be2e426ca4ffa28164d64a90cc75c570652229847c7009b7aec63c6ba8e977dbdd4f4f
+DIST qttools-everywhere-opensource-src-5.15.9.tar.xz 8898188 BLAKE2B 9ba8c3cab5669d2bfba782efdcd31d8a853ab7b42b653d4cfe9d30d16bedf6ed7cd34f4bbce8a52c40b555693db4e763cb454fadb8fc1630ca0d2ac969f4edca SHA512 ddd2a47fe51e9a6e650123eda097ea037971f01f9210cea9c1d13c7a8e581e436a41c954f83def0a8ee35c30f388627809e3eb4bbf27b5e3ece6a55f7d777067
diff --git a/dev-qt/qtpaths/qtpaths-5.15.9.ebuild b/dev-qt/qtpaths/qtpaths-5.15.9.ebuild
new file mode 100644
index 000000000000..4f1248d19ada
--- /dev/null
+++ b/dev-qt/qtpaths/qtpaths-5.15.9.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} != *9999* ]]; then
+ QT5_KDEPATCHSET_REV=1
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+QT5_MODULE="qttools"
+inherit qt5-build
+
+DESCRIPTION="Command line client to QStandardPaths"
+
+IUSE=""
+
+DEPEND="=dev-qt/qtcore-${QT5_PV}*"
+RDEPEND="${DEPEND}"
+
+QT5_TARGET_SUBDIRS=(
+ src/qtpaths
+)
+
+src_install() {
+ qt5-build_src_install
+ qt5_symlink_binary_to_path qtpaths 5
+}