summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-11-27 01:10:13 -0500
committerIonen Wolkens <ionen@gentoo.org>2023-11-27 03:45:40 -0500
commit2e9331fa56b7f4e8461820c6afbfc978b7f05b46 (patch)
tree058b7dcf6a108ce583c5cedd4ac43911b802ccc1 /dev-qt/qtconnectivity
parentdev-qt/qtcharts: add 6.6.1 (diff)
downloadgentoo-2e9331fa56b7f4e8461820c6afbfc978b7f05b46.tar.gz
gentoo-2e9331fa56b7f4e8461820c6afbfc978b7f05b46.tar.bz2
gentoo-2e9331fa56b7f4e8461820c6afbfc978b7f05b46.zip
dev-qt/qtconnectivity: add 6.6.1
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-qt/qtconnectivity')
-rw-r--r--dev-qt/qtconnectivity/Manifest1
-rw-r--r--dev-qt/qtconnectivity/qtconnectivity-6.6.1.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/dev-qt/qtconnectivity/Manifest b/dev-qt/qtconnectivity/Manifest
index 87e044b37d7a..f6af5baecfe4 100644
--- a/dev-qt/qtconnectivity/Manifest
+++ b/dev-qt/qtconnectivity/Manifest
@@ -1,2 +1,3 @@
DIST qtconnectivity-everywhere-src-6.5.3.tar.xz 986024 BLAKE2B 70ac7bc70d4c4cde2f03acdebf90024977237c208fb342adc0f680ab6bb96e06966ad61c991178bd46638bf5abbcf075159ec48241ef9423ea8b385c53360976 SHA512 d0a8309143545689c7f6f545ae1aa8e1b4e516398bc6cc0d0f0ea3df6a414d6c933d32ae32451134d2a0d7d2c02078e8e46438b0aec59e938e4b8533d4da9457
DIST qtconnectivity-everywhere-src-6.6.0.tar.xz 989076 BLAKE2B 4ad09c18fe259042b8242a52baaccbf0b70d9b4f6f7029513ca90074b9f2b801397115eb9aed95fc2c2503d1fd7aae72942481b058c596f59db5ff06b3775f43 SHA512 f660edbfaa9aefebdb602bb44b2e62b8a5d8dceba4b8c3d73d0f9daf6c29ff5f8953c134dc5af79dfd90b888f97d99e44f91a8e0aee3a51b278747eee2d1c381
+DIST qtconnectivity-everywhere-src-6.6.1.tar.xz 989544 BLAKE2B 5b1f49cf865cf241363f08ff9b2bebefbf718606df8d88f70b30d800a6bd48ecfb740b8385e2d28e2e619cfb2c7d735598cf904473095dedbec508a3d541a0f9 SHA512 b1a1962d881c1965c56cef5226b3eac39613332c96778daf322fa0ccba9aa33677e1943f3bb3f7efbdd8aec81623ca6b59c2340c805346935ef77e7606210dab
diff --git a/dev-qt/qtconnectivity/qtconnectivity-6.6.1.ebuild b/dev-qt/qtconnectivity/qtconnectivity-6.6.1.ebuild
new file mode 100644
index 000000000000..47506d7b4b09
--- /dev/null
+++ b/dev-qt/qtconnectivity/qtconnectivity-6.6.1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="Bluetooth and NFC support library for the Qt6 framework"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64"
+fi
+
+IUSE="+bluetooth nfc smartcard"
+REQUIRED_USE="|| ( bluetooth nfc )"
+
+RDEPEND="
+ ~dev-qt/qtbase-${PV}:6[network]
+ bluetooth? (
+ ~dev-qt/qtbase-${PV}:6[dbus]
+ net-wireless/bluez:=
+ )
+ nfc? (
+ smartcard? ( sys-apps/pcsc-lite )
+ )
+"
+DEPEND="${RDEPEND}"
+
+CMAKE_SKIP_TESTS=(
+ # most hardware tests are auto-skipped, but some still misbehave
+ # if bluez/hardware is available (generally tests here may not be
+ # very relevant without hardware, lists may need to be extended)
+ tst_qbluetoothlocaldevice
+ tst_qbluetoothserver
+ tst_qbluetoothservicediscoveryagent
+ tst_qbluetoothserviceinfo
+ tst_qlowenergycontroller
+)
+
+src_prepare() {
+ qt6-build_src_prepare
+
+ use bluetooth ||
+ sed -i '/add_subdirectory(bluetooth)/d' src/CMakeLists.txt || die
+ use nfc ||
+ sed -i '/add_subdirectory(nfc)/d' src/CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(usev nfc $(qt_feature smartcard pcsclite))
+ )
+
+ qt6-build_src_configure
+}
+
+src_install() {
+ qt6-build_src_install
+
+ # broken (unnecessary) symlink due to add_app() being used over add_tool()
+ use !bluetooth || rm -- "${ED}"/usr/bin/sdpscanner6 || die
+
+ if use test; then
+ local delete=( # sigh
+ "${D}${QT6_BINDIR}"/bluetoothtestdevice
+ "${D}${QT6_BINDIR}"/bttestui
+ "${D}${QT6_BINDIR}"/qlecontroller-server
+ )
+ # using -f given not tracking which tests may be skipped or not
+ rm -f -- "${delete[@]}" || die
+ fi
+}