summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-25 05:04:26 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-25 05:47:50 +0100
commitf71f31d824efbb231b2fea41b7b0b963d309f320 (patch)
tree88536cb623c983d7ff001f883ef1f267a3ed575a /dev-python
parentdev-python/hypothesis: Bump to 6.99.13 (diff)
downloadgentoo-f71f31d824efbb231b2fea41b7b0b963d309f320.tar.gz
gentoo-f71f31d824efbb231b2fea41b7b0b963d309f320.tar.bz2
gentoo-f71f31d824efbb231b2fea41b7b0b963d309f320.zip
dev-python/pyupgrade: Bump to 3.15.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyupgrade/Manifest1
-rw-r--r--dev-python/pyupgrade/pyupgrade-3.15.2.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pyupgrade/Manifest b/dev-python/pyupgrade/Manifest
index 56b90a1e9f65..c051fd276089 100644
--- a/dev-python/pyupgrade/Manifest
+++ b/dev-python/pyupgrade/Manifest
@@ -1 +1,2 @@
DIST pyupgrade-3.15.1.gh.tar.gz 65432 BLAKE2B 2978745edcbbcc3aee5abb14c2b509a3912d1932401e8957e04d0491fa0e6b01521317ef62b6486f80835715f09254e6bb39c6482c2155e8986580c146ad06ca SHA512 5946cd03231e9c56543ac2f1dc4a84c0a4dc8cb44b0f88983a0a02f190a20615e2c2e4b22d8b3ec0d4728482464fe4f87bbd90514e11230776a1d67540170e91
+DIST pyupgrade-3.15.2.gh.tar.gz 65444 BLAKE2B 3e0004452957f4bac9e7bc2fab886fd3e4dc799d7c53d988da1c0515d445cb275463115d9dee495991a1be61adbee7dd72782f2a21985568dd39fd8afe4088d5 SHA512 98ac1629e2bdc0956536b51e96929e7a88a3355364ccc0696cff38d2e6cf4dd5552f91f76644d7977dbdc57ef44ca9942585acd0506ca47e7a4e69c6eb95ed7c
diff --git a/dev-python/pyupgrade/pyupgrade-3.15.2.ebuild b/dev-python/pyupgrade/pyupgrade-3.15.2.ebuild
new file mode 100644
index 000000000000..127ff6fc4c1d
--- /dev/null
+++ b/dev-python/pyupgrade/pyupgrade-3.15.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Tool + pre-commit hook to automatically upgrade syntax for newer Pythons"
+HOMEPAGE="
+ https://github.com/asottile/pyupgrade/
+ https://pypi.org/project/pyupgrade/
+"
+# no tests in sdist, as of 3.3.2
+SRC_URI="
+ https://github.com/asottile/pyupgrade/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="
+ >=dev-python/tokenize-rt-5.2.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest