summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-31 18:36:15 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-31 19:17:05 +0200
commitf24bf7eda686d38dc0cbbc0c6f5fd13983683ccf (patch)
tree046e30f2791bf58c5b755d7aebe36309ede497fc /dev-python
parentdev-python/sphinxcontrib-serializinghtml: Port to py39 (diff)
downloadgentoo-f24bf7eda686d38dc0cbbc0c6f5fd13983683ccf.tar.gz
gentoo-f24bf7eda686d38dc0cbbc0c6f5fd13983683ccf.tar.bz2
gentoo-f24bf7eda686d38dc0cbbc0c6f5fd13983683ccf.zip
dev-python/sphinxcontrib-qthelp: Port to py39
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sphinxcontrib-qthelp/sphinxcontrib-qthelp-1.0.3.ebuild5
1 files changed, 2 insertions, 3 deletions
diff --git a/dev-python/sphinxcontrib-qthelp/sphinxcontrib-qthelp-1.0.3.ebuild b/dev-python/sphinxcontrib-qthelp/sphinxcontrib-qthelp-1.0.3.ebuild
index 53dfdd4ef73b..185b85b3f675 100644
--- a/dev-python/sphinxcontrib-qthelp/sphinxcontrib-qthelp-1.0.3.ebuild
+++ b/dev-python/sphinxcontrib-qthelp/sphinxcontrib-qthelp-1.0.3.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
inherit distutils-r1
@@ -18,8 +18,7 @@ KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 sparc x8
RDEPEND="dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]"
PDEPEND="
>=dev-python/sphinx-2.0[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
+BDEPEND="
test? ( ${PDEPEND} )"
distutils_enable_tests pytest