summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-11 18:41:11 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-11 19:25:37 +0200
commitec6396454248552adef90ea355145c563f67b3af (patch)
tree9e56951be7545cad3483c7565203951c68ab98a2 /dev-python
parentdev-python/httpx: Bump to 0.24.0 (diff)
downloadgentoo-ec6396454248552adef90ea355145c563f67b3af.tar.gz
gentoo-ec6396454248552adef90ea355145c563f67b3af.tar.bz2
gentoo-ec6396454248552adef90ea355145c563f67b3af.zip
dev-python/beartype: Bump to 0.13.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/beartype/Manifest1
-rw-r--r--dev-python/beartype/beartype-0.13.1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/beartype/Manifest b/dev-python/beartype/Manifest
index 4fcc87730cba..5d597ef361f9 100644
--- a/dev-python/beartype/Manifest
+++ b/dev-python/beartype/Manifest
@@ -1,2 +1,3 @@
DIST beartype-0.12.0.gh.tar.gz 874431 BLAKE2B 0ad2a6c852b32427f8f9c5a8915e580601b24551e956d458a64cda4127bffe91a94ff676e2284daed6671e2c94515a234fd74dcb3d8a78616665490d1a780910 SHA512 2724f080a0f423a8b79b080843db696ee607f2e27ef52d726928086b643ebb31abe4e3ae24cae12075e222a21291d301601606640ca281ff98272578d5bf752e
DIST beartype-0.13.0.gh.tar.gz 923713 BLAKE2B 151480693dfd3e30b41b38ef7ad2138ec323992461e2528fb059ac206304113578843dd1053838e3b132df4fff9f1e03706f02aa3d2b136da96f228d51386dd6 SHA512 062776e8d13c75106e1474aeada727562743689ad0131d2e218b222a0befe072f21af59e28bf7e69e1477beefc6cc1dc8cda2a476cf620b68746a3d350d701f5
+DIST beartype-0.13.1.tar.gz 933146 BLAKE2B e008c6be830424a868fde249eafc26d71a914a7de683741f90590f6e7bb3bc06b482d49f5e72742d648413cb785bc78666204adffd348224cd2fd37434f0423c SHA512 9109598ef876c08f63fa5451ef86b3e5c0f2cd334d88259a2d39ffae5fc41ad75122ac8781538c580cdf0c5d429cc15b5be04d5cce2a3392f5a0648e1c2de504
diff --git a/dev-python/beartype/beartype-0.13.1.ebuild b/dev-python/beartype/beartype-0.13.1.ebuild
new file mode 100644
index 000000000000..2ede86b8636b
--- /dev/null
+++ b/dev-python/beartype/beartype-0.13.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Unbearably fast runtime type checking in pure Python"
+HOMEPAGE="
+ https://pypi.org/project/beartype/
+ https://github.com/beartype/beartype/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ test? (
+ dev-python/mypy[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # fragile performance test
+ beartype_test/a00_unit/a90_decor/test_decorwrapper.py::test_wrapper_fail_obj_large
+ # test for building docs, apparently broken too
+ beartype_test/a90_func/z90_lib/a00_sphinx
+)