summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-30 18:11:21 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-30 18:18:46 +0200
commiteb80f50effa33dcc3d9880db0731543e7d264f8b (patch)
tree2b54bc7f722b0dba959ed584b6ef98b99c3d6764 /dev-python
parentdev-python/trio: Bump to 0.22.0_p20230530 snapshot (diff)
downloadgentoo-eb80f50effa33dcc3d9880db0731543e7d264f8b.tar.gz
gentoo-eb80f50effa33dcc3d9880db0731543e7d264f8b.tar.bz2
gentoo-eb80f50effa33dcc3d9880db0731543e7d264f8b.zip
dev-python/trio: Enable py3.12
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/trio/trio-0.22.0_p20230530.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/dev-python/trio/trio-0.22.0_p20230530.ebuild b/dev-python/trio/trio-0.22.0_p20230530.ebuild
index 7b5e30f07816..987eea446215 100644
--- a/dev-python/trio/trio-0.22.0_p20230530.ebuild
+++ b/dev-python/trio/trio-0.22.0_p20230530.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{10..11} )
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
inherit distutils-r1
@@ -28,7 +28,9 @@ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
RDEPEND="
>=dev-python/attrs-20.1.0[${PYTHON_USEDEP}]
- >=dev-python/exceptiongroup-1.0.0_rc9[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/exceptiongroup-1.0.0_rc9[${PYTHON_USEDEP}]
+ ' 3.{9..10})
dev-python/idna[${PYTHON_USEDEP}]
dev-python/outcome[${PYTHON_USEDEP}]
dev-python/sniffio[${PYTHON_USEDEP}]
@@ -65,6 +67,11 @@ python_test() {
# incompatible ipython version?
trio/_core/tests/test_multierror.py::test_ipython_exc_handler
)
+ if [[ ${EPYTHON} == python3.12 ]]; then
+ EPYTEST_DESELECT+=(
+ trio/_core/_tests/test_run.py::test_nursery_cancel_doesnt_create_cyclic_garbage
+ )
+ fi
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
epytest -p trio._tests.pytest_plugin -m "not redistributors_should_skip"