summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-17 11:49:08 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-17 14:35:07 +0200
commite9cff165a859a9fbcd4f0e3d0bb37f57574961ee (patch)
tree443fa5913e7864ac8010daae3dc3a0b46cad9fe2 /dev-python
parentnet-misc/networkmanager: Port init script to elogind (diff)
downloadgentoo-e9cff165a859a9fbcd4f0e3d0bb37f57574961ee.tar.gz
gentoo-e9cff165a859a9fbcd4f0e3d0bb37f57574961ee.tar.bz2
gentoo-e9cff165a859a9fbcd4f0e3d0bb37f57574961ee.zip
dev-python/cfn-lint: Bump to 1.7.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/cfn-lint/Manifest1
-rw-r--r--dev-python/cfn-lint/cfn-lint-1.7.1.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/cfn-lint/Manifest b/dev-python/cfn-lint/Manifest
index 886032f22e14..1a0a89e96a3b 100644
--- a/dev-python/cfn-lint/Manifest
+++ b/dev-python/cfn-lint/Manifest
@@ -1,3 +1,4 @@
DIST cfn_lint-1.4.2.tar.gz 2485843 BLAKE2B c2e64721b537ab38cad3c3f6d40c509741fb03f61202d7dace4023f4b5b3a7840b7deb88892d9d282d223756a1e3908680ed166cdf216b0c76abdc29d0749967 SHA512 c9761e253ba77198264eabdd9c4e6a290bb9010533628958853c8d5a0f5f7317338f271588b5cef2ac1667f6ed5e1a6e43a3192aa9ff7202b0ca6db061284818
DIST cfn_lint-1.5.3.tar.gz 2354279 BLAKE2B b8c836db35453efbb27fd050a4cb3090ca99fb050256c4e0b8cd5b634320d677f2ed325894a700127891b614ab70cd436e7af06759f9dbcf58ad45f4b50ee779 SHA512 38ce749f21e6118f129d98d21ecc01bc4f828efce8af9f597f624eff9a062dbceb8c670cfbaa0cf581c14d187094ffe90ada4293679c1e0f77cb3baff3308b26
DIST cfn_lint-1.6.1.tar.gz 2366313 BLAKE2B af7b3e8d5145f3368d4c7b2e86b0ffe441c1f6633de34024e8c10d8cd04625673a25e847c15f30a6778bee8196096ffca58241e3a6f21a750094a3b2845f5493 SHA512 f354fa40677f8b601dabfb12b8715f4eb49f8e8aec72d3b9eeb4a63fabe278c36629f404b193f557b193280d6ecd224f0f0a494f9dfc61a04ebb24d0fe953d67
+DIST cfn_lint-1.7.1.tar.gz 2412588 BLAKE2B 259b548e7fc7704c12ca0191d27dd82ce2a75e33c7462520becf218261ac693308f600719850a357d9948f5d2700846b6bc35781491cc4c0598cc494d1090e3f SHA512 ce4933a1c3cdf25b3911b0e057d60a6ff0753937dbb6a5cdf6a1e0afae3fc1532302ac2572191781337cb6a5f0ae1743409714317f79fb9da55295875bd56b27
diff --git a/dev-python/cfn-lint/cfn-lint-1.7.1.ebuild b/dev-python/cfn-lint/cfn-lint-1.7.1.ebuild
new file mode 100644
index 000000000000..4ec420c8b216
--- /dev/null
+++ b/dev-python/cfn-lint/cfn-lint-1.7.1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="CloudFormation Linter"
+HOMEPAGE="
+ https://github.com/aws-cloudformation/cfn-lint/
+ https://pypi.org/project/cfn-lint/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-sam-translator-1.89.0[${PYTHON_USEDEP}]
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ >=dev-python/jschema-to-python-1.2.3[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-5[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
+ dev-python/junit-xml[${PYTHON_USEDEP}]
+ <dev-python/networkx-4[${PYTHON_USEDEP}]
+ >dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
+ >=dev-python/regex-2021.7.1[${PYTHON_USEDEP}]
+ >=dev-python/sarif-om-1.0.4[${PYTHON_USEDEP}]
+ >=dev-python/sympy-1.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin the deps
+ sed -e 's:~=[0-9.]*::' -i pyproject.toml || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ test/unit/module/test_template.py::TestTemplate::test_build_graph
+ # requires git repo
+ test/unit/module/maintenance/test_update_documentation.py::TestUpdateDocumentation::test_update_docs
+ # Internet
+ test/unit/module/formatters/test_formatters.py::TestFormatters::test_sarif_formatter
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_3
+ # TODO: it looks as if AWS_DEFAULT_REGION didn't work
+ test/unit/module/core/test_run_cli.py::TestCli::test_bad_config
+ test/unit/module/core/test_run_cli.py::TestCli::test_override_parameters
+ test/unit/module/core/test_run_cli.py::TestCli::test_positional_template_parameters
+ test/unit/module/core/test_run_cli.py::TestCli::test_template_config
+ # different graphviz version?
+ test/unit/module/template/test_template.py::TestTemplate::test_build_graph
+ )
+
+ # from tox.ini
+ local -x AWS_DEFAULT_REGION=us-east-1
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}