summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2025-02-20 14:55:36 +0100
committerMichał Górny <mgorny@gentoo.org>2025-02-20 18:08:46 +0100
commitd92931889573594280b4085e99711744c0ec9ce7 (patch)
tree17fd382df6981778a7c696535dbc64c5c8b9ddad /dev-python
parentdev-python/readme-renderer: Enable pypy3.11 (diff)
downloadgentoo-d92931889573594280b4085e99711744c0ec9ce7.tar.gz
gentoo-d92931889573594280b4085e99711744c0ec9ce7.tar.bz2
gentoo-d92931889573594280b4085e99711744c0ec9ce7.zip
dev-python/id: Enable pypy3.11
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/id/id-1.5.0.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-python/id/id-1.5.0.ebuild b/dev-python/id/id-1.5.0.ebuild
index d8f9afc32498..83ca2152d433 100644
--- a/dev-python/id/id-1.5.0.ebuild
+++ b/dev-python/id/id-1.5.0.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=flit
-PYTHON_COMPAT=( pypy3 python3_{10..13} )
+PYTHON_COMPAT=( pypy3 pypy3_11 python3_{10..13} )
inherit distutils-r1
@@ -38,7 +38,7 @@ python_test() {
local EPYTEST_DESELECT=()
case ${EPYTHON} in
- pypy3)
+ pypy3*)
EPYTEST_DESELECT+=(
# https://github.com/di/id/issues/287
test/unit/internal/oidc/test_ambient.py::test_gcp_bad_env