summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-29 06:01:34 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-29 06:12:31 +0100
commitd6073db968d2fa06c6dfc03ba15c930e06a6276c (patch)
treeaaf3622b2077bc80c480148ebc04ca9e7c901d08 /dev-python
parentdev-python/Nuitka: Bump to 1.3.4 (diff)
downloadgentoo-d6073db968d2fa06c6dfc03ba15c930e06a6276c.tar.gz
gentoo-d6073db968d2fa06c6dfc03ba15c930e06a6276c.tar.bz2
gentoo-d6073db968d2fa06c6dfc03ba15c930e06a6276c.zip
dev-python/jupyter_server: Bump to 2.0.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/jupyter_server/Manifest1
-rw-r--r--dev-python/jupyter_server/jupyter_server-2.0.6.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/dev-python/jupyter_server/Manifest b/dev-python/jupyter_server/Manifest
index b5ac4789890a..9467344a7a75 100644
--- a/dev-python/jupyter_server/Manifest
+++ b/dev-python/jupyter_server/Manifest
@@ -1,3 +1,4 @@
DIST jupyter_server-1.19.1.tar.gz 453411 BLAKE2B 800231e7e7ddfcf2a2c2f2725971983d754c76940623ce000e6b86ad503bc6ca68a27e55ca3766193e58184a7148471464dfa9c27076e53ac84b176b8ff65897 SHA512 f4228c73950e49fe26add11c61f3de425b963726908a2df7dae21bb38b986c2ebb6abfc3319ef9e3acbc2fef9579a1a70ac594920985977adf580a082d272368
DIST jupyter_server-2.0.1.tar.gz 680584 BLAKE2B 06ec85e0088f3ab7d08935b2b085c96d4ce9b787895a573024f64af48b78a7c99bbe8fa8330f8536b55d32fd7321a5cb56958a55a6044aec687107d13dce9db0 SHA512 c8d676da5af479ca0492c94615b01f9d2efb0d8e3aefa78437c44997409afeef1eaf7e269ce48047597d83cc82a26602108db17eacddca73179e9042ee145afa
DIST jupyter_server-2.0.5.tar.gz 682705 BLAKE2B ea83b74c105fe7337dfafd725a7f6989b440a7124be73f854900d578439b5a3f0f5056e39056ce28ee07611b742afb4c4b1d1352f123125d4d7080269f217a94 SHA512 6e2af05c1cc6875fd32158bbd70a55f7a05e18af7b264d7d3e966d3d8c1c515927e86a0763e5734bca90b57119183d1ad4e10c44a47d929c6d62b15f78cc18f0
+DIST jupyter_server-2.0.6.tar.gz 686312 BLAKE2B dfa309146e74c646ab28f31a4a7293d2b658771077240179aebd13176151c982035649acf3b78c86ddb06e914e3342e5894fb55f8b8711cb493a6a7c4b259cfa SHA512 186b41b13cc727d0674a49abcb9b3a9aa5b898f0e9e42124e46e862ec62528b4127b159a30352f33e6b91321f1dd3f086f82dca72d5616755bcf3220d154faa6
diff --git a/dev-python/jupyter_server/jupyter_server-2.0.6.ebuild b/dev-python/jupyter_server/jupyter_server-2.0.6.ebuild
new file mode 100644
index 000000000000..2b15b9a6e42a
--- /dev/null
+++ b/dev-python/jupyter_server/jupyter_server-2.0.6.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Core services, APIs, and REST endpoints to Jupyter web applications"
+HOMEPAGE="https://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64"
+
+RDEPEND="
+ >=dev-python/anyio-3.1.0[${PYTHON_USEDEP}]
+ <dev-python/anyio-4[${PYTHON_USEDEP}]
+ dev-python/argon2-cffi[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_client-6.1.1[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_core-4.12.0[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_events-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/nbconvert-6.4.4[${PYTHON_USEDEP}]
+ >=dev-python/nbformat-5.3.0[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/prometheus_client[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-24[${PYTHON_USEDEP}]
+ dev-python/send2trash[${PYTHON_USEDEP}]
+ >=dev-python/terminado-0.8.3[${PYTHON_USEDEP}]
+ >=dev-python/tornado-6.2[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.6.0[${PYTHON_USEDEP}]
+ dev-python/websocket-client[${PYTHON_USEDEP}]
+
+"
+BDEPEND="
+ test? (
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/pytest-console-scripts[${PYTHON_USEDEP}]
+ dev-python/pytest_jupyter[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/pytest-tornasync[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # This fails if your terminal is zsh (and maybe other non-bash as well?)
+ tests/test_terminal.py
+ # Fails because above is ignored
+ tests/auth/test_authorizer.py
+ # Fails with additional extensions installed
+ tests/extension/test_app.py::test_stop_extension
+)
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.0.1-skip-npm.patch"
+)
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest \
+ -p pytest_tornasync.plugin \
+ -p jupyter_server.pytest_plugin \
+ -p pytest_console_scripts \
+ -p pytest_timeout
+}