summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-12-28 20:46:47 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-12-28 21:11:25 +0200
commitcf8c771d2049a67a2c2175d023e98adc98b898f4 (patch)
treef4fe493e7f5f66798d106bcbbef2a620b4342f19 /dev-python
parentdev-java/guava-testlib: add 31.1 (diff)
downloadgentoo-cf8c771d2049a67a2c2175d023e98adc98b898f4.tar.gz
gentoo-cf8c771d2049a67a2c2175d023e98adc98b898f4.tar.bz2
gentoo-cf8c771d2049a67a2c2175d023e98adc98b898f4.zip
dev-python/filelock: add 3.9.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/filelock/Manifest1
-rw-r--r--dev-python/filelock/filelock-3.9.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/filelock/Manifest b/dev-python/filelock/Manifest
index ef74829c91af..89f6d317c77d 100644
--- a/dev-python/filelock/Manifest
+++ b/dev-python/filelock/Manifest
@@ -1,2 +1,3 @@
DIST py-filelock-3.8.0.gh.tar.gz 204748 BLAKE2B 719f965eddf9a76aaa7d3700ffbd29df3856fdcd76aa184b12a1e3b3341a5d8681f05ebd7239b48a0ffbc942aebc8574ff3878177100ba659347a904945b2234 SHA512 a9b63ab9a6697334eb8c561c422e8ec6febd0b7b203c0ebb4cfd1e4281f16cc0ef5145121c90f3c08bec88f13e219c0655142e3d3f856163702a0d32e14cd5ce
DIST py-filelock-3.8.2.gh.tar.gz 204940 BLAKE2B a83fbea21690f82680ab5d024cbca6e52b5f6490854fa1d14a98191a4e56edea41c0a8bda9dd396f8b9c5b83187d9f976011440ca00987fbe4e96cd1e311a244 SHA512 2d5f7f49cf2d112a060156391eeb600040b9ae8619a9795173b9888ee977ec718432beff68bfefca290791b14f8cefca6d2a92defd78132822dc3596493aaa23
+DIST py-filelock-3.9.0.gh.tar.gz 205047 BLAKE2B 3995f7ad27bb09ca75310c4ada7645f2dd16c09ddb39663394f315443851037f2f9cf08eecb507eba521479696ad1004978d3fdd300a7128ac3354fce2e57d5f SHA512 1235ae9ebdb4c84b0c30e68be91e01eb1acbfcd15c85202fa54a3b91e4e507f221926f8886e1ec91acd4f71d2d88c08f536529b4cebfd2de4fb90118f5dc242e
diff --git a/dev-python/filelock/filelock-3.9.0.ebuild b/dev-python/filelock/filelock-3.9.0.ebuild
new file mode 100644
index 000000000000..bcb4d61210d0
--- /dev/null
+++ b/dev-python/filelock/filelock-3.9.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2018-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+MY_P=py-filelock-${PV}
+DESCRIPTION="A platform independent file lock for Python"
+HOMEPAGE="
+ https://github.com/tox-dev/py-filelock/
+ https://pypi.org/project/filelock/
+"
+SRC_URI="
+ https://github.com/tox-dev/py-filelock/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}