summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-02 07:26:36 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-02 08:05:30 +0200
commitc6c36398a05abb4256f1ba561b686ef4fc303665 (patch)
treeb81d29fe305023f6deb664db2b2120d45fcbe0fe /dev-python
parentdev-python/zeroconf: Bump to 0.71.5 (diff)
downloadgentoo-c6c36398a05abb4256f1ba561b686ef4fc303665.tar.gz
gentoo-c6c36398a05abb4256f1ba561b686ef4fc303665.tar.bz2
gentoo-c6c36398a05abb4256f1ba561b686ef4fc303665.zip
dev-python/pytest-httpx: Bump to 0.23.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pytest-httpx/Manifest1
-rw-r--r--dev-python/pytest-httpx/pytest-httpx-0.23.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pytest-httpx/Manifest b/dev-python/pytest-httpx/Manifest
index db323dd6afb9..c99b804273d5 100644
--- a/dev-python/pytest-httpx/Manifest
+++ b/dev-python/pytest-httpx/Manifest
@@ -1 +1,2 @@
DIST pytest-httpx-0.22.0.gh.tar.gz 24409 BLAKE2B 9db6622e4997ddf0a70c1a0ef835b077640b3ce1d1c19792feda573577fac1ecfba16bcb7ecb8e4c1578b345764d8301aa121335a259dc91a4805173a549bea3 SHA512 fd89ce70113608195eb8fa8e3d7465d9d15b5a300e7c00f3c50417ba9b205081671fbda9591bdb16accb1973da00f5d0bede9e73a3351b0652080d4059c5f6d6
+DIST pytest_httpx-0.23.0.tar.gz 28994 BLAKE2B 909fb72d6172fc1a504f1e6ceaf8eb607a5f59fdafc424400567c7ac11ce6d135353be46cd669864b770b5b4dc0403d2c71b3618e733d124cfd86bb88cb76bc5 SHA512 c0ef087bbcc9e214bda19596c11ca38062c8cd14bb10bff36d9faab3ddf326813f30e70dce476b82a9dae72feac3127625920059fd6e64d8b06edf3004a549a6
diff --git a/dev-python/pytest-httpx/pytest-httpx-0.23.0.ebuild b/dev-python/pytest-httpx/pytest-httpx-0.23.0.ebuild
new file mode 100644
index 000000000000..336dab68638d
--- /dev/null
+++ b/dev-python/pytest-httpx/pytest-httpx-0.23.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Send responses to HTTPX using pytest"
+HOMEPAGE="
+ https://colin-b.github.io/pytest_httpx/
+ https://github.com/Colin-b/pytest_httpx/
+ https://pypi.org/project/pytest-httpx/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ =dev-python/httpx-0.24*[${PYTHON_USEDEP}]
+ <dev-python/pytest-8[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest