summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-17 04:43:50 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-17 04:43:50 +0200
commitbdd1102318a43ca0500429c81177ef02e9eab356 (patch)
treeef04ebfe54c46a40df2fe8b44d3d721448e04e3a /dev-python
parentdev-python/httptools: Bump to 0.6.4 (diff)
downloadgentoo-bdd1102318a43ca0500429c81177ef02e9eab356.tar.gz
gentoo-bdd1102318a43ca0500429c81177ef02e9eab356.tar.bz2
gentoo-bdd1102318a43ca0500429c81177ef02e9eab356.zip
dev-python/httptools: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/httptools/Manifest1
-rw-r--r--dev-python/httptools/files/httptools-0.6.2-llhttp-9.patch55
-rw-r--r--dev-python/httptools/httptools-0.6.2.ebuild73
3 files changed, 0 insertions, 129 deletions
diff --git a/dev-python/httptools/Manifest b/dev-python/httptools/Manifest
index 5aeca41590c8..c2ad411f985e 100644
--- a/dev-python/httptools/Manifest
+++ b/dev-python/httptools/Manifest
@@ -1,2 +1 @@
-DIST httptools-0.6.2.gh.tar.gz 15209 BLAKE2B f9dbb15a46db4ff6d9ce418fa9854fe465d22c5ca7b758389f2d132f0e031015faea37241f68e8f47e3957da39de9930481e50d0b08e0308ad7d3bb918fc86bb SHA512 a4f79cfd82b1ab3d1bb4dc50cb4c720cdc5b2f94cb72ef693e4385726a02687f1a45d649c8cc22388f1215c9497f329b67eed90f065859380dbd54dd3046c89b
DIST httptools-0.6.4.gh.tar.gz 15756 BLAKE2B 1f128fb566d677f783798236a12fc1729f819fb4e4cd52f43c4879ac6cff8a5c69fb147fef1dadda89e47b560652b15e7ab07e3e5b00f1e8a6ee23afe2efb879 SHA512 3a2518204b22ce00c1fa3f2387138f768511ff03a2a2ddf0b9c44a4d5de65c93bfd8d3ac9f4e9417805c7c9708a8cb39ec4889e08933fdc029607bcae5b54331
diff --git a/dev-python/httptools/files/httptools-0.6.2-llhttp-9.patch b/dev-python/httptools/files/httptools-0.6.2-llhttp-9.patch
deleted file mode 100644
index 8f5dc017d246..000000000000
--- a/dev-python/httptools/files/httptools-0.6.2-llhttp-9.patch
+++ /dev/null
@@ -1,55 +0,0 @@
-diff --git a/tests/test_parser.py b/tests/test_parser.py
-index a169a9a..d3b8db7 100644
---- a/tests/test_parser.py
-+++ b/tests/test_parser.py
-@@ -6,12 +6,10 @@ from unittest import mock
-
- RESPONSE1_HEAD = b'''HTTP/1.1 200 OK
- Date: Mon, 23 May 2005 22:38:34 GMT
--Server: Apache/1.3.3.7
-- (Unix) (Red-Hat/Linux)
-+Server: Apache/1.3.3.7 (Unix) (Red-Hat/Linux)
- Last-Modified: Wed, 08 Jan 2003 23:11:55 GMT
- ETag: "3f80f-1b6-3e1cb03b"
--Content-Type: text/html;
-- charset=UTF-8
-+Content-Type: text/html; charset=UTF-8
- Content-Length: 130
- Accept-Ranges: bytes
- Connection: close
-@@ -33,7 +31,7 @@ CHUNKED_REQUEST1_1 = b'''POST /test.php?a=b+c HTTP/1.1\r
- User-Agent: Fooo\r
- Host: bar\r
- Transfer-Encoding: chunked\r
--
-+\r
- 5\r\nhello\r\n6\r\n world\r\n'''
-
- CHUNKED_REQUEST1_2 = b'''0\r\nVary: *\r\nUser-Agent: spam\r\n\r\n'''
-@@ -42,7 +40,7 @@ CHUNKED_REQUEST1_3 = b'''POST /test.php?a=b+c HTTP/1.1\r
- User-Agent: Fooo\r
- Host: bar\r
- Transfer-Encoding: chunked\r
--
-+\r
- b\r\n+\xce\xcfM\xb5MI,I\x04\x00\r\n0\r\n\r\n'''
-
-
-@@ -54,7 +52,7 @@ Sec-WebSocket-Protocol: sample\r
- Upgrade: WebSocket\r
- Sec-WebSocket-Key1: 4 @1 46546xW%0l 1 5\r
- Origin: http://example.com\r
--
-+\r
- Hot diggity dogg'''
-
- UPGRADE_RESPONSE1 = b'''HTTP/1.1 101 Switching Protocols
-@@ -89,7 +87,7 @@ class TestResponseParser(unittest.TestCase):
- self.assertEqual(len(headers), 8)
- self.assertEqual(headers.get(b'Connection'), b'close')
- self.assertEqual(headers.get(b'Content-Type'),
-- b'text/html; charset=UTF-8')
-+ b'text/html; charset=UTF-8')
-
- self.assertFalse(m.on_body.called)
- p.feed_data(bytearray(RESPONSE1_BODY))
diff --git a/dev-python/httptools/httptools-0.6.2.ebuild b/dev-python/httptools/httptools-0.6.2.ebuild
deleted file mode 100644
index fea990adb5f0..000000000000
--- a/dev-python/httptools/httptools-0.6.2.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{10..13} )
-
-inherit distutils-r1
-
-DESCRIPTION="A collection of framework independent HTTP protocol utils"
-HOMEPAGE="
- https://github.com/MagicStack/httptools/
- https://pypi.org/project/httptools/
-"
-# sdist is missing cython source files, as of 0.6.2
-SRC_URI="
- https://github.com/MagicStack/httptools/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-
-# don't ask me why they use both
-DEPEND="
- net-libs/http-parser:=
- net-libs/llhttp:=
-"
-RDEPEND="
- ${DEPEND}
-"
-BDEPEND="
- dev-python/cython[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-PATCHES=(
- # https://github.com/MagicStack/httptools/issues/111
- # https://github.com/MagicStack/httptools/pull/112
- "${FILESDIR}/${P}-llhttp-9.patch"
-)
-
-src_configure() {
- cat > setup.cfg <<-EOF || die
- [build_ext]
- use_system_llhttp = true
- use_system_http_parser = true
- cython_always = true
- EOF
-}
-
-python_test() {
- local EPYTEST_DESELECT=()
-
- case ${EPYTHON} in
- pypy3)
- EPYTEST_DESELECT+=(
- # error message mismatches
- # https://github.com/MagicStack/httptools/issues/16#issuecomment-1114181747
- tests/test_parser.py::TestResponseParser::test_parser_response_2
- tests/test_parser.py::TestRequestParser::test_parser_request_4
- tests/test_parser.py::TestUrlParser::test_parser_url_10
- )
- ;;
- esac
-
- rm -rf httptools || die
- epytest tests
-}