summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-07 11:27:13 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-07 11:27:13 +0200
commitb973812635d7156ab4b75b6a7a7bac292131c2ca (patch)
treeb4cfb5916389bdb36b10f3b43a9e0b52dca7fdb4 /dev-python
parentdev-python/httpcore: Enable pypy3 (diff)
downloadgentoo-b973812635d7156ab4b75b6a7a7bac292131c2ca.tar.gz
gentoo-b973812635d7156ab4b75b6a7a7bac292131c2ca.tar.bz2
gentoo-b973812635d7156ab4b75b6a7a7bac292131c2ca.zip
dev-python/hatchling: Enable pypy3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/hatchling/hatchling-0.22.0.ebuild19
1 files changed, 13 insertions, 6 deletions
diff --git a/dev-python/hatchling/hatchling-0.22.0.ebuild b/dev-python/hatchling/hatchling-0.22.0.ebuild
index 72e3b3bb04e8..992bc68216bc 100644
--- a/dev-python/hatchling/hatchling-0.22.0.ebuild
+++ b/dev-python/hatchling/hatchling-0.22.0.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=standalone
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
inherit distutils-r1
@@ -35,11 +35,13 @@ RDEPEND="
BDEPEND="
${RDEPEND}
test? (
- dev-python/atomicwrites[${PYTHON_USEDEP}]
- dev-python/click[${PYTHON_USEDEP}]
- dev-python/httpx[${PYTHON_USEDEP}]
- dev-python/platformdirs[${PYTHON_USEDEP}]
- dev-python/rich[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/atomicwrites[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/httpx[${PYTHON_USEDEP}]
+ dev-python/platformdirs[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ ' 'python*')
)
"
@@ -52,6 +54,11 @@ python_compile() {
}
python_test() {
+ if [[ ${EPYTHON} != python* ]]; then
+ einfo "Skipping tests on ${EPYTHON}"
+ return
+ fi
+
local -x EPYTEST_DESELECT=(
# these run pip to install stuff
tests/backend/dep/test_core.py::test_dependency_found