summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-04 08:46:12 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-04 08:46:12 +0100
commitb4fd4f4a654aee4d7556fb7da145e60386d0193c (patch)
treef2368ff5f457946ef4b85025e8e820427d6a77cd /dev-python
parentdev-vcs/git-filter-repo: Bump to 2.47.0 (diff)
downloadgentoo-b4fd4f4a654aee4d7556fb7da145e60386d0193c.tar.gz
gentoo-b4fd4f4a654aee4d7556fb7da145e60386d0193c.tar.bz2
gentoo-b4fd4f4a654aee4d7556fb7da145e60386d0193c.zip
dev-python/line-profiler: Bump to 4.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/line-profiler/Manifest1
-rw-r--r--dev-python/line-profiler/line-profiler-4.2.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/line-profiler/Manifest b/dev-python/line-profiler/Manifest
index e961efc57d9d..1283416da0a6 100644
--- a/dev-python/line-profiler/Manifest
+++ b/dev-python/line-profiler/Manifest
@@ -1 +1,2 @@
DIST line_profiler-4.1.3.gh.tar.gz 103226 BLAKE2B 209fe81bfd29cad1fe5866af792294d956a8f5d4d20948335a418aa0c7c3c5ff23e271c49cfc6cf228287cb1031e00a0f540fc88f52ccc3a0c329443de17b188 SHA512 cc8367b40558647f097e33152bd1d8b241720a1ed79c1f1930a7958e333cecdf38bc7d1ab0a8ebfb11e3251fa076966076ec42a8b633dfcb9de0c598c02b8b93
+DIST line_profiler-4.2.0.gh.tar.gz 105578 BLAKE2B 5ccef934619986e225e338e6e8b99bc2182c571b8c5377df829d83365bafb0a23eefd5cdbe4bba92a728bc6ac3299084fb61177d342c9a0034c4fc1f9d69b45b SHA512 1ed1324445f3189d7a7b9528c96b0251e1a44faace43c9ca14ecafbead60134138803cabb7c355f7b943bed85720f53689fd40260f02c98dc8597128b945ce01
diff --git a/dev-python/line-profiler/line-profiler-4.2.0.ebuild b/dev-python/line-profiler/line-profiler-4.2.0.ebuild
new file mode 100644
index 000000000000..be13f5e4f4d7
--- /dev/null
+++ b/dev-python/line-profiler/line-profiler-4.2.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=line_profiler-${PV}
+DESCRIPTION="Line-by-line profiler"
+HOMEPAGE="
+ https://github.com/pyutils/line_profiler/
+ https://pypi.org/project/line-profiler/
+"
+SRC_URI="
+ https://github.com/pyutils/line_profiler/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/ipython[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/ubelt[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export LINE_PROFILER_BUILD_METHOD=cython
+
+python_test() {
+ cd tests || die
+ epytest
+}