summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2022-12-20 15:33:03 +0100
committerJakov Smolić <jsmolic@gentoo.org>2022-12-20 16:06:13 +0100
commit90bdc89e8a350a0b0b9872ee2a35e5d61ac75723 (patch)
treeae5a1a7127ccd5b0b8684d48f2bfc48a801274ab /dev-python
parentdev-util/comparator: treeclean (diff)
downloadgentoo-90bdc89e8a350a0b0b9872ee2a35e5d61ac75723.tar.gz
gentoo-90bdc89e8a350a0b0b9872ee2a35e5d61ac75723.tar.bz2
gentoo-90bdc89e8a350a0b0b9872ee2a35e5d61ac75723.zip
dev-python/ws4py: treeclean
Closes: https://bugs.gentoo.org/845909 Closes: https://bugs.gentoo.org/659792 Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/ws4py/Manifest1
-rw-r--r--dev-python/ws4py/files/ws4py-0.5.1-python3.7+-compatibility.patch93
-rw-r--r--dev-python/ws4py/metadata.xml13
-rw-r--r--dev-python/ws4py/ws4py-0.5.1-r1.ebuild59
-rw-r--r--dev-python/ws4py/ws4py-9999.ebuild59
5 files changed, 0 insertions, 225 deletions
diff --git a/dev-python/ws4py/Manifest b/dev-python/ws4py/Manifest
deleted file mode 100644
index 7f62255c2b2b..000000000000
--- a/dev-python/ws4py/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST ws4py-0.5.1.tar.gz 116673 BLAKE2B 31db304800f0d3da61dc4c1a3381a8fcfcfa8f16b36d916311cc32f1d294c9f7b3627dac673edf824f529f485f825ca418ab1e1a8a2fda5583c6a6a1bd9b752c SHA512 4c90d66d37fb5bdc8f7fc9fd184b20a7dc2dae811ecf3a041477e3c26a2577008be7041799daca5b8c0de65cb2454022a6c135cf02534ca98b6946abbfce0e11
diff --git a/dev-python/ws4py/files/ws4py-0.5.1-python3.7+-compatibility.patch b/dev-python/ws4py/files/ws4py-0.5.1-python3.7+-compatibility.patch
deleted file mode 100644
index 12b14111634a..000000000000
--- a/dev-python/ws4py/files/ws4py-0.5.1-python3.7+-compatibility.patch
+++ /dev/null
@@ -1,93 +0,0 @@
-From: Matthias Klose <doko@ubuntu.com>
-Date: Sun, 29 Jul 2018 09:01:36 +0200
-Subject: Fix compatibility with Python 3.7.
-Origin: http://launchpadlibrarian.net/380629852/python-ws4py_0.4.2+dfsg1-2_0.4.2+dfsg1-2ubuntu1.diff.gz
-Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=903529
-
----
- test/autobahn_test_servers.py | 4 ++--
- ws4py/async_websocket.py | 9 +++++++--
- ws4py/server/tulipserver.py | 7 ++++++-
- 3 files changed, 15 insertions(+), 5 deletions(-)
-
-diff --git a/test/autobahn_test_servers.py b/test/autobahn_test_servers.py
-index 3e33f82..8b77954 100644
---- a/test/autobahn_test_servers.py
-+++ b/test/autobahn_test_servers.py
-@@ -142,7 +142,7 @@ def run_python_wsgi(host="127.0.0.1", port=9002):
- """
- run_python_wsgi_async(host, port, False)
-
--def run_python_wsgi_async(host="127.0.0.1", port=9010, async=True):
-+def run_python_wsgi_async(host="127.0.0.1", port=9010, async_=True):
- """
- Runs wsgi server on python 2.x with async middleware"
- """
-@@ -153,7 +153,7 @@ def run_python_wsgi_async(host="127.0.0.1", port=9010, async=True):
- from ws4py.server.wsgiutils import WebSocketWSGIApplication
-
- app = WebSocketWSGIApplication(handler_cls=EchoWebSocket)
-- if async:
-+ if async_:
- def middleware(app):
- def later(environ, start_response):
- for part in app(environ, start_response):
-diff --git a/ws4py/async_websocket.py b/ws4py/async_websocket.py
-index 9e2a4c7..096763d 100644
---- a/ws4py/async_websocket.py
-+++ b/ws4py/async_websocket.py
-@@ -18,6 +18,11 @@ delegated_generator_websocket_on_top_of_asyncio.py
- import asyncio
- import types
-
-+try: # pragma: no cover
-+ asyncio_ensure_future = asyncio.ensure_future # Python >= 3.5
-+except AttributeError: # pragma: no cover
-+ asyncio_ensure_future = getattr(asyncio, 'async') # Python < 3.5
-+
- from ws4py.websocket import WebSocket as _WebSocket
- from ws4py.messaging import Message
-
-@@ -84,7 +89,7 @@ class WebSocket(_WebSocket):
- def closeit():
- yield from self.proto.writer.drain()
- self.proto.writer.close()
-- asyncio.async(closeit())
-+ asyncio.asyncio_ensure_future(closeit())
-
- def _write(self, data):
- """
-@@ -94,7 +99,7 @@ class WebSocket(_WebSocket):
- def sendit(data):
- self.proto.writer.write(data)
- yield from self.proto.writer.drain()
-- asyncio.async(sendit(data))
-+ asyncio.asyncio_ensure_future(sendit(data))
-
- @asyncio.coroutine
- def run(self):
-diff --git a/ws4py/server/tulipserver.py b/ws4py/server/tulipserver.py
-index 2786c16..ce2e9fb 100644
---- a/ws4py/server/tulipserver.py
-+++ b/ws4py/server/tulipserver.py
-@@ -6,6 +6,11 @@ import io
-
- import asyncio
-
-+try: # pragma: no cover
-+ asyncio_ensure_future = asyncio.ensure_future # Python >= 3.5
-+except AttributeError: # pragma: no cover
-+ asyncio_ensure_future = getattr(asyncio, 'async') # Python < 3.5
-+
- from ws4py import WS_KEY, WS_VERSION
- from ws4py.exc import HandshakeError
- from ws4py.websocket import WebSocket
-@@ -40,7 +45,7 @@ class WebSocketProtocol(asyncio.StreamReaderProtocol):
- #self.stream.set_transport(transport)
- asyncio.StreamReaderProtocol.connection_made(self, transport)
- # Let make it concurrent for others to tag along
-- f = asyncio.async(self.handle_initial_handshake())
-+ f = asyncio.asyncio_ensure_future(self.handle_initial_handshake())
- f.add_done_callback(self.terminated)
-
- @property
diff --git a/dev-python/ws4py/metadata.xml b/dev-python/ws4py/metadata.xml
deleted file mode 100644
index bcbb23469491..000000000000
--- a/dev-python/ws4py/metadata.xml
+++ /dev/null
@@ -1,13 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <!-- maintainer-needed -->
- <use>
- <flag name="client">Install client modules</flag>
- <flag name="server">Install server modules</flag>
- </use>
- <upstream>
- <remote-id type="github">Lawouach/WebSocket-for-Python</remote-id>
- <remote-id type="pypi">ws4py</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-python/ws4py/ws4py-0.5.1-r1.ebuild b/dev-python/ws4py/ws4py-0.5.1-r1.ebuild
deleted file mode 100644
index 7313ee949cf5..000000000000
--- a/dev-python/ws4py/ws4py-0.5.1-r1.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# We could depend on dev-python/cherrypy when USE=server, but
-# that is an optional component ...
-# Same for dev-python/tornado and USE=client ... so why not???
-# pypy is viable but better with a cutdown set of deps
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} )
-PYTHON_REQ_USE="threads(+)?"
-
-MY_PN="WebSocket-for-Python"
-
-inherit distutils-r1
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/Lawouach/${MY_PN}.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/Lawouach/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 arm x86"
- S="${WORKDIR}/${MY_PN}-${PV}"
-fi
-
-DESCRIPTION="WebSocket client and server library for Python 2 and 3 as well as PyPy"
-HOMEPAGE="https://github.com/Lawouach/WebSocket-for-Python"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="+client +server test +threads"
-RESTRICT="!test? ( test )"
-# doc build requires sphinxcontrib ext packages absent from portage
-
-RDEPEND=">=dev-python/greenlet-0.4.1[${PYTHON_USEDEP}]
- >=dev-python/cython-0.19.1[${PYTHON_USEDEP}]
- client? ( >=dev-python/tornado-3.1[${PYTHON_USEDEP}] )
- server? ( >=dev-python/cherrypy-3.2.4[${PYTHON_USEDEP}] )"
-
-DEPEND="test? (
- >=dev-python/cherrypy-3.2.4[${PYTHON_USEDEP}]
- >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
- )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.5.1-python3.7+-compatibility.patch
-)
-
-python_test() {
- # testsuite displays an issue with mock under py3 but is non fatal
- "${EPYTHON}" -m unittest discover || die "Tests failed under ${EPYTHON}"
-}
-
-python_install() {
- distutils-r1_python_install
- use client || rm -rf "${D}$(python_get_sitedir)"/ws4py/client
- use server || rm -rf "${D}$(python_get_sitedir)"/ws4py/server
-}
diff --git a/dev-python/ws4py/ws4py-9999.ebuild b/dev-python/ws4py/ws4py-9999.ebuild
deleted file mode 100644
index 3818a848170e..000000000000
--- a/dev-python/ws4py/ws4py-9999.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# We could depend on dev-python/cherrypy when USE=server, but
-# that is an optional component ...
-# Same for dev-python/tornado and USE=client ... so why not???
-# pypy is viable but better with a cutdown set of deps
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} )
-PYTHON_REQ_USE="threads(+)?"
-
-MY_PN="WebSocket-for-Python"
-
-inherit distutils-r1
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/Lawouach/${MY_PN}.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/Lawouach/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 arm ~x86"
- S="${WORKDIR}/${MY_PN}-${PV}"
-fi
-
-DESCRIPTION="WebSocket client and server library for Python 2 and 3 as well as PyPy"
-HOMEPAGE="https://github.com/Lawouach/WebSocket-for-Python"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="+client +server test +threads"
-RESTRICT="!test? ( test )"
-# doc build requires sphinxcontrib ext packages absent from portage
-
-RDEPEND=">=dev-python/greenlet-0.4.1[${PYTHON_USEDEP}]
- >=dev-python/cython-0.19.1[${PYTHON_USEDEP}]
- client? ( >=dev-python/tornado-3.1[${PYTHON_USEDEP}] )
- server? ( >=dev-python/cherrypy-3.2.4[${PYTHON_USEDEP}] )"
-
-DEPEND="test? (
- >=dev-python/cherrypy-3.2.4[${PYTHON_USEDEP}]
- >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
- )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.5.1-python3.7+-compatibility.patch
-)
-
-python_test() {
- # testsuite displays an issue with mock under py3 but is non fatal
- "${EPYTHON}" -m unittest discover || die "Tests failed under ${EPYTHON}"
-}
-
-python_install() {
- distutils-r1_python_install
- use client || rm -rf "${D}$(python_get_sitedir)"/ws4py/client
- use server || rm -rf "${D}$(python_get_sitedir)"/ws4py/server
-}