summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-02 13:27:16 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-02 13:27:16 +0200
commit823c3f8ce982601e6caa50ae0d2bba7d94e2e2b6 (patch)
tree8dd7e135e41e1c8541fecc0c53aa8376ebf40195 /dev-python
parentdev-python/DBUtils: Clean MY_P up (diff)
downloadgentoo-823c3f8ce982601e6caa50ae0d2bba7d94e2e2b6.tar.gz
gentoo-823c3f8ce982601e6caa50ae0d2bba7d94e2e2b6.tar.bz2
gentoo-823c3f8ce982601e6caa50ae0d2bba7d94e2e2b6.zip
dev-python/DBUtils: PEP517, py3.11
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/DBUtils/DBUtils-3.0.2-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/DBUtils/DBUtils-3.0.2-r1.ebuild b/dev-python/DBUtils/DBUtils-3.0.2-r1.ebuild
new file mode 100644
index 000000000000..20fcb08c9bda
--- /dev/null
+++ b/dev-python/DBUtils/DBUtils-3.0.2-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Database connections for multi-threaded environments"
+HOMEPAGE="
+ https://webwareforpython.github.io/DBUtils/
+ https://github.com/WebwareForPython/DBUtils/
+ https://pypi.org/project/DBUtils/
+"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests unittest
+
+python_install_all() {
+ dodoc docs/*.rst
+ rm docs/*.rst || die
+ local HTML_DOCS=( docs/. )
+ distutils-r1_python_install_all
+}