summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-18 02:59:43 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-18 02:59:43 +0200
commit773eb82a602e4b623e26efe0916846bc0ca49a91 (patch)
tree22e26f5d4512e0fb95a88124bd49f5b768078915 /dev-python
parentdev-python/cfn-lint: Bump to 1.7.2 (diff)
downloadgentoo-773eb82a602e4b623e26efe0916846bc0ca49a91.tar.gz
gentoo-773eb82a602e4b623e26efe0916846bc0ca49a91.tar.bz2
gentoo-773eb82a602e4b623e26efe0916846bc0ca49a91.zip
dev-python/cfn-lint: Bump to 1.8.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/cfn-lint/Manifest1
-rw-r--r--dev-python/cfn-lint/cfn-lint-1.8.0.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/cfn-lint/Manifest b/dev-python/cfn-lint/Manifest
index b725c6aabd75..7f042643fe84 100644
--- a/dev-python/cfn-lint/Manifest
+++ b/dev-python/cfn-lint/Manifest
@@ -3,3 +3,4 @@ DIST cfn_lint-1.5.3.tar.gz 2354279 BLAKE2B b8c836db35453efbb27fd050a4cb3090ca99f
DIST cfn_lint-1.6.1.tar.gz 2366313 BLAKE2B af7b3e8d5145f3368d4c7b2e86b0ffe441c1f6633de34024e8c10d8cd04625673a25e847c15f30a6778bee8196096ffca58241e3a6f21a750094a3b2845f5493 SHA512 f354fa40677f8b601dabfb12b8715f4eb49f8e8aec72d3b9eeb4a63fabe278c36629f404b193f557b193280d6ecd224f0f0a494f9dfc61a04ebb24d0fe953d67
DIST cfn_lint-1.7.1.tar.gz 2412588 BLAKE2B 259b548e7fc7704c12ca0191d27dd82ce2a75e33c7462520becf218261ac693308f600719850a357d9948f5d2700846b6bc35781491cc4c0598cc494d1090e3f SHA512 ce4933a1c3cdf25b3911b0e057d60a6ff0753937dbb6a5cdf6a1e0afae3fc1532302ac2572191781337cb6a5f0ae1743409714317f79fb9da55295875bd56b27
DIST cfn_lint-1.7.2.tar.gz 2412586 BLAKE2B 5ec2034dce3c347411408723ebd1e00143c8b2428364cd33591c260fddb1911d595398121dba356d5179737400ac56fa4077ce8458d0b061c886284e152052b8 SHA512 7c9f785ecb08e937f21be47dea736719b1c7afac2b2989e65f84745e220657a0e3ac3427fa53ece4c5fe51b7880fb9da04c9eac7bd509f43978255ec5706f434
+DIST cfn_lint-1.8.0.tar.gz 2376789 BLAKE2B 927a7e789167d5adf04f6a76b309b62b4a2b128db6b1db6a46a771289bc8e6826d021c44209b7dcd711feded2836d10db7727c61daa9f8ef2254a7080c3f30d7 SHA512 e55b24a6e60b4d96317f541787f7828205d04c51816dc5684c37a129b6ff0240e8a0616f15d7fd6917ea18f90d5892c0221fad53fa916cea7a3cd689c1a3c7c2
diff --git a/dev-python/cfn-lint/cfn-lint-1.8.0.ebuild b/dev-python/cfn-lint/cfn-lint-1.8.0.ebuild
new file mode 100644
index 000000000000..4ec420c8b216
--- /dev/null
+++ b/dev-python/cfn-lint/cfn-lint-1.8.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="CloudFormation Linter"
+HOMEPAGE="
+ https://github.com/aws-cloudformation/cfn-lint/
+ https://pypi.org/project/cfn-lint/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-sam-translator-1.89.0[${PYTHON_USEDEP}]
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ >=dev-python/jschema-to-python-1.2.3[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-5[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
+ dev-python/junit-xml[${PYTHON_USEDEP}]
+ <dev-python/networkx-4[${PYTHON_USEDEP}]
+ >dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
+ >=dev-python/regex-2021.7.1[${PYTHON_USEDEP}]
+ >=dev-python/sarif-om-1.0.4[${PYTHON_USEDEP}]
+ >=dev-python/sympy-1.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin the deps
+ sed -e 's:~=[0-9.]*::' -i pyproject.toml || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ test/unit/module/test_template.py::TestTemplate::test_build_graph
+ # requires git repo
+ test/unit/module/maintenance/test_update_documentation.py::TestUpdateDocumentation::test_update_docs
+ # Internet
+ test/unit/module/formatters/test_formatters.py::TestFormatters::test_sarif_formatter
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_3
+ # TODO: it looks as if AWS_DEFAULT_REGION didn't work
+ test/unit/module/core/test_run_cli.py::TestCli::test_bad_config
+ test/unit/module/core/test_run_cli.py::TestCli::test_override_parameters
+ test/unit/module/core/test_run_cli.py::TestCli::test_positional_template_parameters
+ test/unit/module/core/test_run_cli.py::TestCli::test_template_config
+ # different graphviz version?
+ test/unit/module/template/test_template.py::TestTemplate::test_build_graph
+ )
+
+ # from tox.ini
+ local -x AWS_DEFAULT_REGION=us-east-1
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}