summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-09 07:57:48 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-09 08:01:20 +0100
commit511c50896d38329085f7508d07d843c76ac8eb4a (patch)
treeb8f932a60cbe380c31adc2d8e465bfbfaec07678 /dev-python
parentdev-python/trove-classifiers: Bump to 2024.1.8 (diff)
downloadgentoo-511c50896d38329085f7508d07d843c76ac8eb4a.tar.gz
gentoo-511c50896d38329085f7508d07d843c76ac8eb4a.tar.bz2
gentoo-511c50896d38329085f7508d07d843c76ac8eb4a.zip
dev-python/pytest-check: Bump to 2.2.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pytest-check/Manifest1
-rw-r--r--dev-python/pytest-check/pytest-check-2.2.4.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pytest-check/Manifest b/dev-python/pytest-check/Manifest
index c9f88e593655..33b2ff6ca2a6 100644
--- a/dev-python/pytest-check/Manifest
+++ b/dev-python/pytest-check/Manifest
@@ -1,2 +1,3 @@
DIST pytest_check-2.2.2.tar.gz 26353 BLAKE2B 90e95aaddfb3f595b7f0ac7fe8f75cc0dbe173dfcd30aa888cebca9e61ddd67a1a25bb5e152151c86c7bd6144f6875622c8c3a53c3453281b94f2e74a4b465e5 SHA512 27f6df34450db762fb6656b255d34bf6656bacefc68cdd050e100dcf53df1406c6983a509c7b7cc3cc37664c06d3798254a350ba9c0ebcf9095cb7aa1bd11557
DIST pytest_check-2.2.3.tar.gz 26778 BLAKE2B 7f573415a70a600d071c7dae5fae4fc0ed56a81553de3696cbb4f0c1e43a7e2fadd8d256846be5feeaa74c43afaae47dc0782dfd1fddc3607ee9fdcf74769239 SHA512 735d0edcb9b075fc8661892eda63830feeb1b54ff5a63a5956ba5529ce87b499f2137c7a0503813ad1509b591635692d23d77344c244a93826b331d17d262d91
+DIST pytest_check-2.2.4.tar.gz 27197 BLAKE2B 48bc72055d439d91e6609253b778932222fdedd20a834a45636ed1d1ff98648853122780cdbe11c3c784aa98a0a67d443aa17e1d2ef1d5fe3d82dc617f20e093 SHA512 d527040900a4c0e779fe1a970d15b70c80978a5c4848e9bbf4dd5de9e3c338c5facaf70a7ed5362da5bdfaab75fc1129665e351c373fa013060f794d23a0e36f
diff --git a/dev-python/pytest-check/pytest-check-2.2.4.ebuild b/dev-python/pytest-check/pytest-check-2.2.4.ebuild
new file mode 100644
index 000000000000..19b540aee910
--- /dev/null
+++ b/dev-python/pytest-check/pytest-check-2.2.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="pytest plugin that allows multiple failures per test"
+HOMEPAGE="
+ https://github.com/okken/pytest-check/
+ https://pypi.org/project/pytest-check/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/colorama-0.4.6[${PYTHON_USEDEP}]
+ >=dev-python/pytest-7.0.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest