summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-29 16:10:41 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-29 16:28:00 +0100
commit4e4ba87d66f9ccd5378b148569f295f139e4275d (patch)
tree18eabddc0c05eddb7b7f05dc52c315b9c4e928f1 /dev-python
parentdev-python/flask-paginate: Bump to 2024.3.28 (diff)
downloadgentoo-4e4ba87d66f9ccd5378b148569f295f139e4275d.tar.gz
gentoo-4e4ba87d66f9ccd5378b148569f295f139e4275d.tar.bz2
gentoo-4e4ba87d66f9ccd5378b148569f295f139e4275d.zip
dev-python/irc: Bump to 20.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/irc/Manifest1
-rw-r--r--dev-python/irc/irc-20.4.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/irc/Manifest b/dev-python/irc/Manifest
index 6a476a43188a..831c9481bae6 100644
--- a/dev-python/irc/Manifest
+++ b/dev-python/irc/Manifest
@@ -1 +1,2 @@
DIST irc-20.3.1.tar.gz 91115 BLAKE2B f2d89ee1a31edd163d3921f01e47ff865198a6cccf0efefe0a6a8ade2038dad91864f89756a4aaef578b85d57415cf6bda9f307250ead939d66e9fa0525d94bd SHA512 b8ecc313907c006d2dbf493e216a78d73e49e63a5c48f5672a4b33f0432a66e6c411b7807094f582a6be2d421bd020b2c7304cfbdcccfaeda046df4c370e1ba3
+DIST irc-20.4.0.tar.gz 91215 BLAKE2B 39244605b7ad47d4fd9c22b4040f14ad46ec79c339e1ffd8451fad04a3d2b7c4945d8474f4c9c9cf3c620cfc3b0298123ba21844849d5070cc85993f46997025 SHA512 ff75593cf9606c724232517c8340beb115ceda254acb5989c043bd0653f215b928b663570c98c27b845cc7431ea142514c85968e3e3b9bda0406ce799a2b1d2e
diff --git a/dev-python/irc/irc-20.4.0.ebuild b/dev-python/irc/irc-20.4.0.ebuild
new file mode 100644
index 000000000000..e4bd5bdf4e88
--- /dev/null
+++ b/dev-python/irc/irc-20.4.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="IRC client framework written in Python"
+HOMEPAGE="
+ https://github.com/jaraco/irc/
+ https://pypi.org/project/irc/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+IUSE="examples"
+
+RDEPEND="
+ dev-python/jaraco-collections[${PYTHON_USEDEP}]
+ >=dev-python/jaraco-functools-1.20[${PYTHON_USEDEP}]
+ >=dev-python/jaraco-itertools-1.8[${PYTHON_USEDEP}]
+ dev-python/jaraco-logging[${PYTHON_USEDEP}]
+ dev-python/jaraco-stream[${PYTHON_USEDEP}]
+ dev-python/jaraco-text[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ >=dev-python/tempora-1.6[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools-scm-3.4.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ if use examples; then
+ docompress -x "/usr/share/doc/${PF}/scripts"
+ dodoc -r scripts
+ fi
+ distutils-r1_python_install_all
+}