summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-22 07:25:30 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-22 13:32:19 +0100
commit484d8af619006c2a29242a7eff11a0e110c5e622 (patch)
tree6f318997ac5e88f7eb3b733cc43bfc427648a4f7 /dev-python
parentdev-python/yarl: Bump to 1.18.0 (diff)
downloadgentoo-484d8af619006c2a29242a7eff11a0e110c5e622.tar.gz
gentoo-484d8af619006c2a29242a7eff11a0e110c5e622.tar.bz2
gentoo-484d8af619006c2a29242a7eff11a0e110c5e622.zip
dev-python/keystoneauth1: Bump to 5.9.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/keystoneauth1/Manifest1
-rw-r--r--dev-python/keystoneauth1/keystoneauth1-5.9.0.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/keystoneauth1/Manifest b/dev-python/keystoneauth1/Manifest
index fe4bd8756c48..95f8bd3f7328 100644
--- a/dev-python/keystoneauth1/Manifest
+++ b/dev-python/keystoneauth1/Manifest
@@ -1 +1,2 @@
DIST keystoneauth1-5.8.0.tar.gz 278617 BLAKE2B 93437140316d1f353c42f3e8face97d9510c4a795f5c5c7c29b7dbd7c66887a819d71a66f35ebbda3851174cc9c738f53d8edc35a940e4c06a0b4cec19db36d8 SHA512 a427c9a6339cce57e53b78ee3e33276a87753e4cee44fe5dfbc85c7d54bc95bbc1e4536a26c8d1be1ef5a392e9095d529fd64df0ce61f1a4a4c0ba8078b2cddd
+DIST keystoneauth1-5.9.0.tar.gz 285336 BLAKE2B bfabd55f6048b78e03d4e65449357b3389842c292192e85a8c290070e0c349bf3e2d43168c2ac35bdd01222f65cd65676b7c3cb71a3b058e606778159e341d33 SHA512 bd16923a8819f9a097f414f3d0128aeb45733c7c3555dc21514c086322b30bb2d3e59ae9762888b78dce24480e6183e389f03041c7b3903d9456020d777fe866
diff --git a/dev-python/keystoneauth1/keystoneauth1-5.9.0.ebuild b/dev-python/keystoneauth1/keystoneauth1-5.9.0.ebuild
new file mode 100644
index 000000000000..02ecf6b73f91
--- /dev/null
+++ b/dev-python/keystoneauth1/keystoneauth1-5.9.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="This package contains tools for authenticating to an OpenStack-based cloud"
+HOMEPAGE="
+ https://opendev.org/openstack/keystoneauth/
+ https://github.com/openstack/keystoneauth/
+ https://pypi.org/project/keystoneauth1/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/iso8601-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/os-service-types-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4.12[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/betamax-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oauthlib-0.6.2[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.13[${PYTHON_USEDEP}]
+ >=dev-python/requests-kerberos-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-mock-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/testresources-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # fragile to test runner name
+ keystoneauth1/tests/unit/test_session.py::SessionTests::test_user_agent
+ # broken betamax
+ keystoneauth1/tests/unit/test_betamax_fixture.py::TestBetamaxFixture::test_keystoneauth_betamax_fixture
+)
+
+EPYTEST_IGNORE=(
+ # require hacking
+ keystoneauth1/tests/unit/test_hacking_checks.py
+)