summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-10 08:05:06 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-10 08:15:22 +0200
commit44eece2aba14bb80f843281483607d3ece460d80 (patch)
tree9b5d80e759df8b2212b5713b5b7cd4acf74a8912 /dev-python
parentdev-python/django-otp: Bump to 1.4.0 (diff)
downloadgentoo-44eece2aba14bb80f843281483607d3ece460d80.tar.gz
gentoo-44eece2aba14bb80f843281483607d3ece460d80.tar.bz2
gentoo-44eece2aba14bb80f843281483607d3ece460d80.zip
dev-python/pyghmi: Bump to 1.5.69
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyghmi/Manifest1
-rw-r--r--dev-python/pyghmi/pyghmi-1.5.69.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pyghmi/Manifest b/dev-python/pyghmi/Manifest
index 2c2b5162a013..b46215597c84 100644
--- a/dev-python/pyghmi/Manifest
+++ b/dev-python/pyghmi/Manifest
@@ -1,2 +1,3 @@
DIST pyghmi-1.5.67.tar.gz 256905 BLAKE2B 497193e057a4a2e285ba109fc58cf59c77dbef69c73abeabe7fa88629af7c3c961488cd0df173edb81a4b6574893d4db4c43bcd7d8f8c93b5c10bdf768ab9e2e SHA512 db2e16a873db52ebffbfbdf4b03ba22eca462ecf498b0704602cf52257fff2021d0cd7f71161377a3e87029771c2cbb0f8090b215f7da2efeecb8bfaadaadd82
DIST pyghmi-1.5.68.tar.gz 257045 BLAKE2B 02c89b71ad9077ff127d00bffd9d788f21a49ee1fa0103042a9c406e9d530f386e1126fcdd58792424200d46a39e4128ce3902af91ff034628dcec20f249fbd0 SHA512 538a77de22cfb16652e0e7c36e17b638ede1b93b98cf2439eaa2ddbe95a8e85fcc42b624014639b229e045fc697dba9157dc8375cc88f25fb46ac0caef4b117e
+DIST pyghmi-1.5.69.tar.gz 257074 BLAKE2B af1b93bda37aa078c4a04f68970f86a2f6b7c005ed762977d8297bdb4ff8e89c972ec24342ccb226a6cb43d6085f89f23e4e8547e1632275accea0fc5f5558ff SHA512 ad6837b61748ff045196109050fc743e0335b9037e06c723be86e12c42569f6e46b2c004148b4ce4416d0e67967bf6b7596bc10bca30323e2eca11da54067f21
diff --git a/dev-python/pyghmi/pyghmi-1.5.69.ebuild b/dev-python/pyghmi/pyghmi-1.5.69.ebuild
new file mode 100644
index 000000000000..f4adcb0eed3b
--- /dev/null
+++ b/dev-python/pyghmi/pyghmi-1.5.69.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A pure python implementation of IPMI protocol"
+HOMEPAGE="
+ https://opendev.org/x/pyghmi/
+ https://pypi.org/project/pyghmi/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/cryptography-2.1[${PYTHON_USEDEP}]
+ dev-python/pbr[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.6.5[${PYTHON_USEDEP}]
+ >=dev-python/subunit-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest