summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-02 09:54:45 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-02 09:56:38 +0100
commit3eed37d78a0c0505f3932ac7f7b6b0d8359249bb (patch)
tree4ddd4d1b875c1e16677a887e81f7ff3de2649a37 /dev-python
parentdev-python/thunarx-python: Remove old (diff)
downloadgentoo-3eed37d78a0c0505f3932ac7f7b6b0d8359249bb.tar.gz
gentoo-3eed37d78a0c0505f3932ac7f7b6b0d8359249bb.tar.bz2
gentoo-3eed37d78a0c0505f3932ac7f7b6b0d8359249bb.zip
dev-python/numexpr: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/numexpr/Manifest1
-rw-r--r--dev-python/numexpr/numexpr-2.7.2.ebuild50
2 files changed, 0 insertions, 51 deletions
diff --git a/dev-python/numexpr/Manifest b/dev-python/numexpr/Manifest
index 848f084a426e..062ed0316caf 100644
--- a/dev-python/numexpr/Manifest
+++ b/dev-python/numexpr/Manifest
@@ -1,2 +1 @@
-DIST numexpr-2.7.2.gh.tar.gz 118982 BLAKE2B b032f00c36ffadb88cf9a4cd6323137b920bce48ec73f88f006d3186f9a8c1d75a11ceb6bd32f412cba5c10cbe3cb518cdbdb19ef022100fcc408fc82ede9881 SHA512 41946df6d642e226b4a38b11d5db67ef91d63d56b33d3b52f09377c022d236ea4e9a5aaaf380737d18405ee25109260ae60f79d0c9465b95de14465f41c40075
DIST numexpr-2.7.2.r1.gh.tar.gz 119099 BLAKE2B d424dd89761ecdad3e5a35a5c8b41f089c6eb7c9ca10a4309fb489bb7ab60c0b77863c1675583014265c057e27f3b9584a35e0ac6232044ed5f8b8c32fd330d6 SHA512 d786aeb3597a6b2196e92f364934a0bbc518c7973252c38f1e93c317d55220270b5d61320d7a465c87da979ec68e988b25182d527e0e96aa3a898f20a6997802
diff --git a/dev-python/numexpr/numexpr-2.7.2.ebuild b/dev-python/numexpr/numexpr-2.7.2.ebuild
deleted file mode 100644
index 62702d7a6f58..000000000000
--- a/dev-python/numexpr/numexpr-2.7.2.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1 flag-o-matic
-
-DESCRIPTION="Fast numerical array expression evaluator for Python and NumPy"
-HOMEPAGE="https://github.com/pydata/numexpr"
-SRC_URI="
- https://github.com/pydata/numexpr/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86 ~amd64-linux ~x86-linux"
-IUSE="mkl"
-
-RDEPEND="
- >=dev-python/numpy-1.6[${PYTHON_USEDEP}]
- mkl? ( sci-libs/mkl )
-"
-
-python_prepare_all() {
- # TODO: mkl can be used but it fails for me
- # only works with mkl in tree. newer mkl will use pkgconfig
- if use mkl; then
- use amd64 && local ext="_lp64"
- cat > site.cfg <<- _EOF_ || die
- [mkl]
- library_dirs = ${MKLROOT}/lib/em64t
- include_dirs = ${MKLROOT}/include
- mkl_libs = mkl_solver${ext}, mkl_intel${ext}, \
- mkl_intel_thread, mkl_core, iomp5
- _EOF_
- fi
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- pushd "${BUILD_DIR}"/lib >/dev/null || die
- "${EPYTHON}" \
- -c "import sys,numexpr; sys.exit(0 if numexpr.test().wasSuccessful() else 1)" \
- || die
- pushd >/dev/null || die
-}